Installing kdk's kdelibdocs_kdoc2, exec-prefix woe

Matt Gumbley mgumbley at enigmadata.co.uk
Fri Mar 3 09:20:35 UTC 2000


Hello Walter,
Thanks for the swift reply...

"W. Tasin" wrote:
> 
> Matt Gumbley wrote:
> > 1) if your exec-prefix != prefix, configure stops during configuration
> > of kdesgmltools, complaining that it can't find your kwm. Changing lines
> > 789 and 790 of kdesgmltools/configure to:
> >
> > if test -n "/usr/local/kde/bin /opt/local/kde/bin $KDEDIR/bin
> > $exec_prefix/bin"; then
> >  for dir in /usr/local/kde/bin /opt/local/kde/bin $KDEDIR/bin
> > $exec_prefix/bin; do
> 
> sorry but patching this won´t help...
> I even want to know where your kwm is installed... and where your KDEDIR
> env. variable
> points to...
> 
> how do you invoke configure ?? which additional parameter do you apply?

After my patch, the configure "worked" (i.e. didn't drop out saying that
it couldn't find kwm).

I used:
./configure --prefix=/opt/kde --exec-prefix=/opt/kde/Sol2

(/opt/kde being a symlink to my actual kde install tree, which I was
hoping to build on a couple of different platforms, hence splitting with
exec-prefix; I'm using egcs 2.91.66 on Solaris 2.6, with the rest of the
GNU toolchain at near-latest-versions.)

> > 2) I've installed with make install, but this doesn't seem to have
> > installed the prebuilt kdelibs documentation. make install in
> > kdelibdocs_kdoc2 doesn't seem to do anything other than create
> > directories to hold the docs (under /opt/kde/share/doc/HTML/en, which I
> > assume is fine). What's wrong? Is there some magic Makefile target
> > that'll do it all?
> 
> really strange... hmmm... the documentation will be installed under
> /opt/kde/share/doc/HTML/en/kdelibs
> Maybe you have to set the documentation path manually inside KDevelop,
> because your "old" kdevelop configuration does still point on the wrong
> directory.

I tried this(Options/Kdevelop Setup/Documentation, changing
KDE-Libraries-Doc), but kdevelop said that it doesn't lead to the
correct path. 

Of course, if this was closed source, I'd be stuck now ;-)
Looking in kdevelop/kdevelop/ckdevsetupdlg.cpp, line 683, it's looking
for kdecore/index.html, which hasn't been installed under
/opt/kde/share/doc/HTML/en/kdelibs (the directory exists after a make
install, with nothing in it - it seems that the Makefile in
kdelibdocs_kdoc2 isn't doing the copy.)

> Has the c_cpp_reference been installed correctly? to check this have a
> look at
> /opt/kde/share/doc/HTML/en/kdevelop/reference
> there have to be three directories C, CPLUSPLUS, GRAPHICS

Again, directories have been created, with no contents - except for
C/CONTRIB/SNIP, which has some source, and C/CONTRIB/YABL.

Kind regards,

Matt.

-- 
Matt J. Gumbley,  Software Engineer | Enigma Data Systems Ltd.
Email: mgumbley at enigmadata.co.uk    | Chelsea House, 8-14 The Broadway,
Tel: +44 (0)1444 476500 |  Direct:  | Haywards Heath, West Sussex.
Fax: +44 (0)1444 476501 |  476510   | RH16 3AP England.




More information about the KDevelop mailing list