Here we go again

OS owensavill at compuserve.com
Wed Mar 1 23:02:14 UTC 2000


Normally I would agree, except I have been using kdevelop since the early days.

This is not an unknown situation. My description of it as an ancient problem
was not inaccurate. Early versions definitely suffered from this, well
documented, problem. My frustration comes from having gone from 1.0beta4 to 1.1
it has come back. Nothing else has changed on my system except kdevelop. My qt
path is still the same, my KDE path is still the same, my library paths are
still the same, the Qt includes are still installed, I still haven't
overwritten Qt-1.4 with Qt2. Therefore I maintain that kdevelop, for me, has
become frustrating again. 

I am not trying to belittle your work. On the contrary, I have been an avid
supporter of kdevelop since the afore mentioned early days. If this were not
true I would not have struggled through all the problems that I, as a simple
end user and not a system guru, have experienced. I was very happy with
kdevelop and using it quite frequently. For me this kind of problem is a show
stopper. I don't believe I have ever really examined /etc/ld.so.conf ! To me if
a tool cannot find something, especially something that stops it dead in it
tracks, it should ask the user where it is. Having to setup half a dozen exports
is all very well, but considering how polished the rest of kdevelop now is
this, in my opinion, lets it down.

I am sorry if my original e-mail made you angry, but it is just how I feel,

Owen

On Wed, 01 Mar 2000, you wrote:
> On Wed, 01 Mar 2000, you wrote:
> > I installed 1.1, that was a mistake !
> 
> I don't think so, 1.1 is by far the most stable and feature-full release ever.
> 
> > Once again I'm faced with an ancient problem. Namely 'checking for Qt...
> > configure: error: Qt- 1.4 (libraries) not found. Please check your
> > installation!  ***failed***'
> 
> This is NOT a problem of KDevelop but of your installation (as the text says).
> There are several reasons for this:
> a) You didn't export the QTDIR variable to the right Qt path
> (you will also need a correct KDEDIR later in the ./configure process)
> b) You didn't add the $(QTDIR)/lib to your /etc/ld.so.conf (and running
> ldconfig after it) or to the LD_LIBRARY_PATH (you will need $(KDEDIR)/lib
> later on, too)
> c) You didn't install the Qt includes (should be package qt-devel or similar)
> (and maybe qt-compat)
> d) You overwrote the 1.4 libs with your 2.0 libs, I guess you should totally
> uninstall qt-2.0 if you don't need it, because it will surely conflict with
> other software as well if you don't know how to setup it in the right way.
> 
> > Working with kdevelop has once again become very frustrating !
> 
> You didn't work with it, you didn't even get it to compile - so "working with
> kdevelop" can't be "frustrating" yet;  q.e.d.
> 
> PS: Please rethink your writing style ('mistake', 'frustrating' ect. in this
> usage are no words which make it easy to others to try to help you!!)  
> -- 
> Martin Piskernig
> <mpiskernig at kdevelop.de>       ICQ: 24015591
> The KDevelop Team           www.kdevelop.org





More information about the KDevelop mailing list