Here we go again

W. Tasin tasin at e-technik.fh-muenchen.de
Wed Mar 1 20:25:56 UTC 2000


OS wrote:
> 
> I installed 1.1, that was a mistake !

Didn´t find that...

> 
> Once again I'm faced with an ancient problem. Namely 'checking for Qt...
> configure: error: Qt- 1.4 (libraries) not found. Please check your
> installation!  ***failed***'

there are several ways to get it worked.
Did you try it?
several switches should make it possible:

configure [--with-qt-dir=...] [--with-qt-includes=...]
[--with-qt-libraries=...]

and of course:
configure --help 
!!!!!

the acinclude.m4 (which is used for detecting the pathes) searches in
the following dirs...
for the qt-libraries:

$QTDIR/lib $QTDIR $QTLIB /usr/lib/qt/lib /usr/X11R6/lib /usr/lib
/usr/local/qt/lib /usr/lib/qt /usr/lib/qt2/lib and where the x-libraries
were found.

in this order... (as you can see... many directories)

and it searches for the filemask libqt.* inside one of these
directories.

After finding the first directory on which this rule apply it tries to
compile a little program. If THIS will succeed you are able to run
qt-applications and configure would go ahead.

To be on the save side I advice to remove config.cache before invoking
./configure

If your distribution is an exoctic one and you can´t find your path
inside the list above you should set $QTDIR or $QTLIB... in a way that
your shell will know it after the command!!

if you find your qt-lib-path inside this list the problem is another one
and you should have a look in the config.log... there is written why
conftest (the so called test application) couldn´t be compiled.

> 
> Surely after this much time it would be possible to tell kdevelop where to find
> libraries, include files etc.. Stuff the idea of setting QTDIR, this has NEVER
> worked !

a standard file of KDE is used (and I, personally, think these
algorithms are great)... so you will get the same trouble with other KDE
application, which apply to this algorithm.

> 
> So, hopefully I looked, and guess what ! I can tell it where to find Qt2 but
> not Qt-1.4 !!!
> 
> The old method was to randomly re-install gcc, libstdc++, Qt and kdevelop
> until it magically started working. Several days later and this method no
> longer appears to work.

re-installing the stuff then it worked???
Sounds really strange... 

> 
> Working with kdevelop has once again become very frustrating !
> 
> Owen

Walter 

BTW: Flaming around won´t get all the stuff compiled...
I wish you to get kdevelop working, creating a project, publishing it,
having success with it and at the end....
bug reports like this!

-- 
oohhh sveglia.... il mondo e' ammalato, ma x colpa di chi.........
(Zucchero)
:-------W. Tasin, FB 04,
FHM-------------------PGP-KeyID:0x7961A645----------:
<Key-Fingerprint: 1610 835F 0080 32F4 6140  6CF7 A7D0 44CD 7961A645>
<http://wwwkeys.pgp.net:11371/pks/lookup?op=index&search=0x7961A645&fingerprint=on>




More information about the KDevelop mailing list