D13876: Display more readable tooltip text

Andrew Chen noreply at phabricator.kde.org
Thu Jul 26 13:05:29 BST 2018


andrewc added inline comments.

INLINE COMMENTS

> sitter wrote in widgetEvents.cpp:190
> You could probably move the `\n` out of the i18n call, and prepend it always. It doesn't need localization and it being not mid-string seems like something that can easily get lost when translating.

I agree, but wouldn't that mean the translators would have to re-translate this string? I wonder if it's worth it

> sitter wrote in summaryWidget.cpp:148
> Doesn't this undo some of the i18n in the original code?

I moved the i18n to this part:

  if (strcmp("used", m_focus->file()->name8Bit()) == 0) {
      string = i18nc("Tooltip of used space on the partition, %1 is path, %2 is size", "%1\nUsed: %2",..
  } else if (strcmp("free", m_focus->file()->name8Bit()) == 0) {
      string = i18nc("Tooltip of free space on the partition, %1 is path, %2 is size", "%1\nFree: %2",..

My logic is the context will be less confusing to translators if they see used or free instead of another variable "%2".

REVISION DETAIL
  https://phabricator.kde.org/D13876

To: andrewc, sandsmark, sitter
Cc: kde-utils-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-utils-devel/attachments/20180726/21ffa46c/attachment-0001.html>


More information about the Kde-utils-devel mailing list