Frameworks compiler and Qt requirements after Qt 5.7?

Mark Gaiser markg85 at
Fri Jun 26 23:25:11 BST 2015

On Fri, Jun 26, 2015 at 10:51 PM, Alexander Potashev <aspotashev at>

> Hi everyone,
> 2015-06-26 18:46 GMT+03:00 Martin Gräßlin <mgraesslin at>:
> > Thus I think the question about compiler requirement and Qt requirement
> are
> > not coupled. Just because we raise the one or the other doesn't mean we
> should
> > raise both.
> Correct. Consider the following workflow: the user installs the latest
> Qt 5.7 from binary packages and builds the latest KF5 from Git. He
> will only need gcc-4.5. But if we bumped KF5 requirements to gcc-4.7,
> then the user would need to update gcc for no good reason.
> Mark,
> In my opinion you had to start this kind of discussion with
> emphasizing the new features in Qt 5.{6,7} and in new versions of
> compilers that would help us make KF5 better. For me this is still
> unclear.
> --
> Alexander Potashev

Your GCC argument is wrong (unless you mistyped versions). Qt 5.7 is going
to require GCC 4.7 so a distribution shipping the binary package will
certainly have a GCC version that can compile Qt 5.7. It would make no
sense for frameworks to require anything lower if the thing it's build with
(Qt) requires a higher compiler versions.

Anyhow, it clearly looks like i'm way ahead of this discussion. I thought
this was a good moment with Qt finishing their LTS plans and having a quite
clear picture of what Qt 5.7 is going to require.
To be continued in about a year or so i guess :)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the kde-core-devel mailing list