[Tellico-users] Import audio CD data no longer works

Bill Gee bgee at campercaver.net
Mon Nov 17 12:19:40 UTC 2014

Hi Robby -

I ran the ldd command on my system.  It does not list any libkcd* libraries.  
I ran the output of ldd through sort and extracted a few lines before and 
after the point that libkcddb should have appeared.  See below ...

Thanks - Bill Gee

=======  extract from ldd /usr/bin/tellico | sort

        libjson-c.so.2 => /lib64/libjson-c.so.2 (0x0000003dd0000000)
        libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x0000003db7200000)
        libkabc.so.4 => /lib64/libkabc.so.4 (0x000000336de00000)
        libkcal.so.4 => /lib64/libkcal.so.4 (0x0000003367600000)
        libkdecore.so.5 => /lib64/libkdecore.so.5 (0x0000003eb7400000)
        libkdeui.so.5 => /lib64/libkdeui.so.5 (0x0000003eb7a00000)
        libkemoticons.so.4 => /lib64/libkemoticons.so.4 (0x0000003367e00000)
        libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x0000003db7e00000)


On Sunday, November 16, 2014 22:19:04 Robby Stephenson wrote:
> Bill,
> One way you can check about how Tellico was compiled is to used the ldd
> command.
> ldd `which tellico`
> (Those are back-ticks). That will list all the libraries against which
> Tellico was compiled. See if libkcddb shows up in that list.
> Looking at the Fedora packaging info, I do see that back in September,
> the build switched from using the full kdemultimedia-devel pkg to the
> libkcddb-devel pkg. So in theory, it should be working.
> http://pkgs.fedoraproject.org/cgit/tellico.git/commit/?id=20bff0647d38c2ca53
> 9d628029816de5b8c456e2
> But this rpm info does not show a dependency on libkcddb which is puzzling.
> http://rpmfind.net/linux/RPM/fedora/updates/20/i386/tellico-2.3.9-1.fc20.i68
> 6.html
> Since I don't have access to a Fedora system, that's about all I can check.
> Robby

More information about the tellico-users mailing list