[Tellico-users] Re: Tellico Namespace Errors When Searching the Z39.50 ADS Server

Nathan Clarke N.Clarke at curtin.edu.au
Tue Feb 1 06:31:13 UTC 2011

Hi Robby,

Thanks for taking some time to look at this.  The options I have are:

   * Source type: z39.50 Server
   * The "Updating from source should overwrite user data" box is not 
   * Available Fields boxes for Address, Abstract and Illustrator are 
all checked (though I've tried various combinations of this to no effect).
   * The "Use preset server" box is not checked.
   * Host: z3950.adsabs.harvard.edu
   * Port: 210
   * Database: AST
   * Character set: utf-8 (I've tried all of these to no effect too)
   * Format: MODS
   * User: [none set]
   * Password: [none set]


On 31/01/11 22:02, Robby Stephenson wrote:
> Hi Nathan,
> I apologize for the late reply.
> You're right, it does appear to be a namespace issue. The z39.50 searching
> goes through a somewhat complicated process of being converted from MODS to
> MARC to XML, so there are certainly plenty of points where the XSLT can get
> hairy.
> What are the options you're using for the ADS z39.50 target so I can do some
> testing myself? (database name, character set, etc.?)
> In the meantime, though it's not as flexible, you could take a shot using a
> script I wrote a while back, if you were interested.
> http://tellico-project.org/search-saonasa-astrophysics-data-system
> Robby
> On Wednesday 12 January 2011, Nathan Clarke wrote:
>> In Tellico's data source properties, I added a new Z39.50 data source
>> for the ADS Astronomy Database (hosted on z3950.adsabs.harvard.edu).
>> However, when I attempt to perform a search (using key words that I know
>> are in the ADS data base), I get no results, and in the shell (from
>> where I launched Tellico) I see lots of error messages of the form below:
>> namespace error : Namespace prefix dc on description is not defined
>> n>http://adsabs.harvard.edu/abs/2011AAS...21714304M</dc:relation><dc:desc
>> ription
>> I am no XML expert, but this appears to be some sort of XML namespace
>> issue.
>> Can you offer any advice on this?  Is there any way that I can fix it?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: N_Clarke.vcf
Type: text/x-vcard
Size: 393 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/tellico-users/attachments/20110131/3f71d78c/attachment.vcf>

More information about the tellico-users mailing list