KDEPIM (16.12) and Gpgme minimum requirement

Sandro KnauƟ sknauss at kde.org
Thu Nov 3 19:39:13 UTC 2016


Hey,

> That's good news from my (KGpg) point of view, as we were recently in a
> discussion which versions we need to support. We do not need gpgme itself,
> but we use the headers to get some algorithm defines.
> 
> Does that version of GpgME bring a CMake config file with it so we can drop
> the FindGpgME.cmake we copied somewhere from?

As far as I see, no you can't drop it at the moment. 1.7.1 only creates cmake 
files for Qt (QGpgme) and C++(Gpgmepp) bindings. But maybe if you ask Andre 
nicely he will add cmake files for C interface too in 1.7.2 :)

Also one thing to remake about QGpgme/Gpgmepp, there internal version numbers 
are 7.0.0(QGpgme) and 6.0.0(Gpgmepp) in 1.7.1, but these are unified to the 
same version like Gpgme to 1.7.2. Please be aware of this if you add a minimum 
version for those.

Best regards,

sandro


More information about the release-team mailing list