Perl version in KDELibs

Raphael Kubo da Costa kubito at
Mon Jun 6 11:18:48 CEST 2011

Michael Pyne <mpyne at> writes:

> On Sunday, June 05, 2011 22:07:25 Raphael Kubo da Costa wrote:
>> Frederik Schwarzer <schwarzer at> writes:
>> > So I changed the affected script and let it require Perl 5.10.
>> > 
>> > Now I wanted to backport the change to 4.6 but I am not sure if that is
>> > OK due to the version bump and the with it changed dependency. So I
>> > looked at kdelibs' CMakeLists.txt and found out that it does not state
>> > a version.
>> > 
>> > Does that mean it would also be satisfied by Perl 5.4 or something?
>> Yes.
>> > Should we set a minimum version there?
>> Well, we use CMake's FindPerl.cmake, which does not check Perl's version
>> at all. If that's really needed, we could add a FindPerl.cmake to
>> kdelibs, but the kde-buildsystem mailing list is a better place to
>> discuss that.
> AFAICS CMake's FindPerl supports requesting a minimum version just fine, we 
> just were not setting a minimum version to look for.

I'm using CMake 2.8.4 here, and its FindPerl.cmake only looks for an
executable called "perl", without any version checking.

FindPerlLibs.cmake, on the other hand, does that version check if
required. Perhaps we could use that instead of FindPerl
(FindPerlLibs.cmake does `include(FindPerl)')?

More information about the release-team mailing list