Perl version in KDELibs
schwarzer at kde.org
Mon Jun 6 10:13:56 CEST 2011
[Michael Pyne - Montag, 6. Juni 2011 03:14:14]
> On Sunday, June 05, 2011 22:07:25 Raphael Kubo da Costa wrote:
> > Frederik Schwarzer <schwarzer at kde.org> writes:
> > > So I changed the affected script and let it require Perl 5.10.
> > >
> > > Now I wanted to backport the change to 4.6 but I am not sure if that is
> > > OK due to the version bump and the with it changed dependency. So I
> > > looked at kdelibs' CMakeLists.txt and found out that it does not state
> > > a version.
> > >
> > > Does that mean it would also be satisfied by Perl 5.4 or something?
> > Yes.
> > > Should we set a minimum version there?
> > Well, we use CMake's FindPerl.cmake, which does not check Perl's version
> > at all. If that's really needed, we could add a FindPerl.cmake to
> > kdelibs, but the kde-buildsystem mailing list is a better place to
> > discuss that.
> AFAICS CMake's FindPerl supports requesting a minimum version just fine, we
> just were not setting a minimum version to look for.
Where do you see that? The cmake file does not look like it is checking a version
and using a high number in the macro in kdesdk/kioslaves gives me:
-- Found Perl: /usr/bin/perl (Required is at least version "6.10")
See the difference of wording e.g. to:
-- Found SharedMimeInfo: /usr/bin/update-mime-database (found version "0.90", required is "0.40")
where it actually states the version that was found.
So maybe FindPerl does not support version checks after all.
Strange though that it does
Every version of Perl deprecates and drops (or rather replaces) some things so
it might make sence to enable FindPerl to check for specific versions.
> Both Perl 5.8 and 5.10 are unsupported by Perl upstream, so it doesn't make
> sense for us to depend on those or anything earlier.
I think the important bit is what we actually use. If we use features introduced
in 5.10 (as in kdesdk/kioslaves/perldoc/pod2html.pl), we should set 5.10 as the
minimum required version and make sure the script works with 5.12 and 5.14 as well.
5.10 might be unsupported by upstream but not necessarily by distros.
More information about the release-team