Better wording for "port away from"? (was: Re: D23700: view: Port away from foreach loops over members without calls to owner)
Friedrich W. H. Kossebau
kossebau at kde.org
Wed Sep 4 13:41:02 BST 2019
Am Mittwoch, 4. September 2019, 14:15:52 CEST schrieb rhkramer at gmail.com:
> From the peanut gallery: I've had some trouble understanding what this
> change is about, without attempting to read any code. I guess the part
> that I don't get is the phrase: "port away" -- I guess the meaning is to
> change the code (so that, whatever "foreach loops over members without
> calls to owner" is no longer done)?
> (I don't care too much what "foreach loops over members without calls to
> owner" means or does, I just want to confirm that "port away" means
> something like do away with or change the subject code. If it means
> something more technical, a brief explanation or a pointer to a brief
> explanation would be appreciated.
I can see how the very line alone is hard to parse without context. It's the
result of a bad-fated attempt to squeeze all the details into a summary line
of 72 characters (others would even like only 50).
A non-length limited version would be
"subdirectory src/view": "Port" "away from" "Qt's foreach macro, which is
going to be removed in Qt6," "all those" "for-loops over class members" "which
are without calls to the member owning class"
About the "port away from X", as non-native speaker this is a term I have seen
often used to describe the process of changing code from using X, to using
some Y instead.
Happy to be pointed to more English-like wording here, if this is potentially
bogus Germanism :)
More information about the KWrite-Devel