[KimDaBa] KimDaBa snapshot available

Jesper K. Pedersen blackie at blackie.dk
Thu Dec 29 18:36:41 GMT 2005

|    | 1) It doesn't import Kimdaba 2.1 settings (e. g. thumbnail size,
|    |    viewer size, etc.)
|    Thats a feature not a bug *ahem* These settings has move to the KDE
|    setting system, so the backend database is not cluttered with this
|    information. I didn't want to bother converting these, as it rather
|    simple for you the user to change these yourself.
| It's a real pain for users to have to manually convert settings.  The
| fact that they're now in the KDE setting system is irrelevant -- this
| is something kimdaba should be able to do itself.
I completely agree. But unfortunately I have a limited amount of time, so I 
decided I'd rather let the user spent 2 minutes, than I spent 2 days. (Feel 
free to take this task ;-)

|    | 2) There are a number of things in the viewer (e. g. if I click on an
|    |    image) that are extremely slow (take on the order of 30 seconds on
|    |    a 1.8 GHz processor with 1.5 GB RAM).  These appear to be related.
|    |    If I right click on the image and click Show Folder, or click on
|    |    the beach umbrella, the UI pretty much freezes for quite a while.
|    |    I haven't tried to investigate this yet.
|    |
|    |    BTW, what does that beach umbrella icon do, anyway?
|    Jump to context. That is it opens the browser with the current
|    image centered.  I agree that takes a long time, better do some
|    profiling on that some time.  Feel free to help if you want to :-)
| That wouldn't apply to right clicking on the image, would it?
Right clicking on the image where? I dont see any delay neither in the 
thumbnail viewer or in the image viewer.

|    | 3) The first time I tried to use the EXIF Info, the program crashed on
|    |    me.  Unfortunately, I don't have a stack trace, but I did see a
|    |    message on my terminal about sqlite failing to create an "exif"
|    |    table because it already exists.  The next time it worked.
|    That error is shown when the table is created the first time, I
|    dont know why, and it seems to be harmless.
| Whatever the case may be, the seg fault wasn't harmless.
Are we in grumpy mode today? ;-)

All I'm saying is that it likely is not the above error message that crashed 

| Another thing: there isn't any "build all thumbnails" or "remove
| thumbnails" command.  Those were extremely useful.
Thumbnails are now stored in the ~/.thumbnails directory, so if you want all 
of them to be deleted, simply rm -rf ~/.thumbnails

Creating them is far from as slow as it was previously, which is why I removed 
that option.

Jesper K. Pedersen          |  Klarälvdalens Datakonsult
Senior Software Engineer    |  www.klaralvdalens-datakonsult.se
Prinsensgade 4a st.         |
9800 Hjørring               |  Platform-independent
Denmark                     |  software solutions

More information about the Kphotoalbum mailing list