[KimDaBa] KimDaBa snapshot available

Robert L Krawitz rlk at alum.mit.edu
Thu Dec 29 17:57:17 GMT 2005

   From: "Jesper K. Pedersen" <blackie at blackie.dk>
   Date: Thu, 29 Dec 2005 17:40:25 +0100
   Cc: kimdaba at kdab.net

   |    I've tried making a new version, this time without unsermake. Give it a
   | try.
   | That works.
   | Now, for some initial comments:
   | 1) It doesn't import Kimdaba 2.1 settings (e. g. thumbnail size,
   |    viewer size, etc.)

   Thats a feature not a bug *ahem* These settings has move to the KDE
   setting system, so the backend database is not cluttered with this
   information. I didn't want to bother converting these, as it rather
   simple for you the user to change these yourself.

It's a real pain for users to have to manually convert settings.  The
fact that they're now in the KDE setting system is irrelevant -- this
is something kimdaba should be able to do itself.

   | 2) There are a number of things in the viewer (e. g. if I click on an
   |    image) that are extremely slow (take on the order of 30 seconds on
   |    a 1.8 GHz processor with 1.5 GB RAM).  These appear to be related.
   |    If I right click on the image and click Show Folder, or click on
   |    the beach umbrella, the UI pretty much freezes for quite a while.
   |    I haven't tried to investigate this yet.
   |    BTW, what does that beach umbrella icon do, anyway?

   Jump to context. That is it opens the browser with the current
   image centered.  I agree that takes a long time, better do some
   profiling on that some time.  Feel free to help if you want to :-)

That wouldn't apply to right clicking on the image, would it?

   | 3) The first time I tried to use the EXIF Info, the program crashed on
   |    me.  Unfortunately, I don't have a stack trace, but I did see a
   |    message on my terminal about sqlite failing to create an "exif"
   |    table because it already exists.  The next time it worked.

   That error is shown when the table is created the first time, I
   dont know why, and it seems to be harmless.

Whatever the case may be, the seg fault wasn't harmless.

Another thing: there isn't any "build all thumbnails" or "remove
thumbnails" command.  Those were extremely useful.

Robert Krawitz                                     <rlk at alum.mit.edu>

Tall Clubs International  --  http://www.tall.org/ or 1-888-IM-TALL-2
Member of the League for Programming Freedom -- mail lpf at uunet.uu.net
Project lead for Gimp Print   --    http://gimp-print.sourceforge.net

"Linux doesn't dictate how I work, I dictate how Linux works."
--Eric Crampton

More information about the Kphotoalbum mailing list