Compiles, yeah! was: Re: KMM compiles now, Gwen fails? was: Re: Compiling on Ubuntu fails at 97 , how to enable KBanking, AqBanking?

Timon timon-kmymoney at
Fri Sep 20 22:10:30 BST 2019

Hi Thomas,

> > yeah! Everything compiles now :-)


For anyone on Ubuntu:

(Concerning dependencies see previous posts ...)

> > 
> > ... but, sadly:
> > configure: WARNING: unrecognized options: --with-qt5-qmake, --with-
> > qt5-moc
> > 
> > ... and then it just leads to the same error as before, see
> > attached
> > file "compile_output_gwen_2.txt".txt
> > 
> > Any ideas?
> I ran into the same problem recently here on openSUSE. The line
>   o qt5dialogbox.moc qt5dialogbox.hpp
> which should actually be
>   moc -o qt5dialogbox.moc qt5dialogbox.hpp
> shows, when some variables are not set correctly. 
> What is the output of "which moc" on your system? I am pretty sure it
> does not find anything. 

$ which moc
$ moc -v
Qt Meta Object Compiler version 63 (Qt 4.8.7)

Hah, so that should be 5.x instead, right?

> What is the output of "which moc-qt5"? Does that show the qt5
> version?

$ which moc-qt5

Alright, hot trail I guess.

>  If any of this is the case (as for me) it helped here to prepend
>   /usr/lib64/qt5/bin/
> to the PATH variable. 

$ ls /usr/lib64/qt5/bin/
ls: cannot access '/usr/lib64/qt5/bin/': No such file or directory

However: /usr/lib/qt5/bin/ exists and contains "moc" :-)

$ /usr/lib/qt5/bin/moc -v
moc 5.9.5

So let's adapt your proposed

export PATH=/usr/lib/qt5/bin/:$PATH

> This now looks like this for me:
> /usr/lib64/qt5/bin:/home/thb/bin:/usr/local/bin:/usr/bin:/bin


> and running simply "moc" starts the Qt5 version

$ moc -v
moc 5.9.5

Looks good, so:

>  and aqbanking/gwenhywfar builds.

Let's immediately try:

I'll document this a bit, even the parts that work. The next person on
Ubuntu might find this useful ...

$ export PATH=/usr/lib/qt5/bin/:$PATH
$ moc -v
moc 5.9.5

$ cd /usr/local/src/
$ rm -rf gwenhywfar
$ git clone
$ autoconf
$ autoconf
$ autoreconf -i
$ ./configure --prefix=/usr/local --with-guis=qt5 --enable-system-
$ make
$ sudo make install

Yeah, that worked just fine :-D

> Older versions of aqbanking allowed to override the name of the
> binary to use for qmake/moc/uic with the variables like you tried but
> that is not available anymore (except for qmake).

I understand.

O.K., now let's immediately build AqBanking as well, with the options
you mentioned:

$ cd /usr/local/src/aqbanking
$ sudo make uninstall
$ cd /usr/local/src/
$ rm -rf aqbanking
$ git clone
$ cd aqbanking
$ export ACLOCAL_FLAGS="-I /usr/local/share/aclocal"
$ make -fMakefile.cvs
$ ./configure --prefix=/usr/local --enable-full-doc 
$ export LD_LIBRARY_PATH=/usr/local/lib
$ make
$ sudo make install

export PATH=/usr/local/bin/:$PATH

And aqbanking-config works as expected.

Today is my lucky day 8-) Or just the last in a long enough series with
quite a bit of help ... whatever, let's continue:


Hmm, apart from the SQLCIPHER=OFF these are in Brendans script config
But wait: /usr/lib64/qt5/plugins does not exist.
=> In Ubuntu 18.04 it's /usr/lib/x86_64-linux-gnu/qt5/plugins

So set that in the script config and:

cd /usr/local/src/kmm

And yesss, it compiles and installs :-D

> Hope that helps.

Yes, this helped a great deal!!

I need to get to bed asap and will be out most of the weekend, might
get the chance to run it on Sunday. Either way:

For now, I'm very happy with the milestone achieved!

Thank you Thomas, Brendan, Jack!



Viele Grüße
Timon Fiddike

More information about the KMyMoney-devel mailing list