[Kmymoney-devel] odd backup error

Thomas Baumgart thb at net-bembel.de
Sat Apr 18 06:10:53 UTC 2015

Good morning (though another one),

On Thursday 16 April 2015 11:52:10 Jack wrote:

> Good morning,
> I just tried to backup my file and got an error about failure to mount
> the directory.  (Of course I didn't copy the exact wording....)  The
> only problem is that the directory is just a folder two levels below my
> home directory, and doesn't need mounting, and I did not check the box
> about needing mounting, and backup has worked fine for years.  This is
> the second time this has happened, and simply restarting KMM fixed the
> problem both times.  I have not otherwise noticed anything strange
> about files or partitions or mounts.  If it happens again, are there
> any specific things I can check to try and figure out the cause?

That is strange. In case the mount option is unchecked, a simple 'echo' 
replaces the mount command. This is just so that the next step in the process 
can be triggered by the successful finish of a command (mount or echo in this 
case). The scenario you describe would happen, when the 'echo' command returns 
an exit code other than 0 (why should it) or the KProcess exitStatus differs 
from QProcess::NormalExit. I can't image why either of the two should happen.

It would be interesting, if you use the backup for the first, second or other 
time after you have started KMyMoney when this happens.

So much for now.




Thomas Baumgart

GPG-FP: E55E D592 F45F 116B 8429   4F99 9C59 DB40 B75D D3BA
The good things about FOSS is that people can see your code and comment it.
The bad thing is that people can see your code and comment it. (asoliverez)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 225 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kmymoney-devel/attachments/20150418/7bcb42e3/attachment.sig>

More information about the KMyMoney-devel mailing list