[Kmymoney-devel] odd backup error

Jack ostroffjh at frontier.com
Sat Apr 18 12:37:48 UTC 2015

On 2015.04.18 02:10, Thomas Baumgart wrote:
> On Thursday 16 April 2015 11:52:10 Jack wrote:
>> I just tried to backup my file and got an error about failure to  
>> mount the directory.  (Of course I didn't copy the exact  
>> wording....)  The only problem is that the directory is just a  
>> folder two levels below my home directory, and doesn't need  
>> mounting, and I did not check the box about needing mounting, and  
>> backup has worked fine for years.  This is the second time this has  
>> happened, and simply restarting KMM fixed the problem both times.  I  
>> have not otherwise noticed anything strange about files or  
>> partitions or mounts.  If it happens again, are there any specific  
>> things I can check to try and figure out the cause?
> That is strange. In case the mount option is unchecked, a simple  
> 'echo' replaces the mount command. This is just so that the next step  
> in the process can be triggered by the successful finish of a command  
> (mount or echo in this case). The scenario you describe would happen,  
> when the 'echo' command returns an exit code other than 0 (why should  
> it) or the KProcess exitStatus differs from QProcess::NormalExit. I  
> can't image why either of the two should happen.
I think that gave me the answer, but I won't have time to test until  
this evening.  For years, I only ran KMM started from the start menu or  
an icon.  Recently, however, I've left those methods to start the  
distro installed version, and have a git version installed in a  
different location which I have to start with a script, from command  
line.  I suspect if I close that console, then the echo will fail  
because KMMs stdout has gone away.

I'll confirm this after I test later.


More information about the KMyMoney-devel mailing list