[Kmymoney-devel] work on models

Alvaro Soliverez asoliverez at gmail.com
Tue Feb 16 13:35:39 CET 2010

2010/2/16 Thomas Baumgart <thb at net-bembel.de>:
> On Monday 15 February 2010 20:58:04 Alvaro Soliverez wrote:
>> 2010/2/15 Cristian Oneţ <onet.cristian at gmail.com>:
>> > În data de Luni 15 Februarie 2010 21:36:12 Alvaro Soliverez a scris:
>> >> I do not have a preference in either case to go one way or the other.
>> >> What I would not like to see, is that some areas of the code have one
>> >> format and the rest has another.
>> >> In matters of format, I prefer to keep diversity out. :)
>> >
>> > I totally agree with you on this. I just saw the models as a separate
>> > module and I thought that we could have a naming convention, uniform for
>> > the models module, without the overhead of a prefix.
>> Good point, but I wouldn't like this module to end like reports, which
>> is very different in some respects from the rest of the code, and that
>> makes it harder to maintain.
> We can probably make that discussion part of the finance sprint. After all, I
> do see the current MyMoneyXX classes and maybe the models as well as part of
> a common code base. So we should have a common understanding with the other
> apps.

Then, for now, let's stick to the existing convention, and if we
change later, we change it for all classes.

More information about the KMyMoney-devel mailing list