Why my installation of 5.2.3 won't parse the code -- a clue (was: Re: 5.2.4 impression)

rhkramer at gmail.com rhkramer at gmail.com
Fri May 10 15:33:08 BST 2019


Further update: I tried starting kdevelop just to check if I had all the 
directories listed that I thought needed to be parsed (aside: I had left out 
one that may be relevant (qt) and added it, but I'm not sure it is relevant.)

Anyway, my intention was to stop kdevelop before it got to 99% parsing in 
order to avoid the hang (I quit at about 54%) but the machine hung anyway.

A few days ago (when the weather was just slightly warmer), I heard beeps 
coming from the machine's audio system (speakers and headphones) -- the 
interval between beeps varied (randomly, afaict) from about 5 seconds to 5 
minutes or longer.

Anyway, I shut the machine down, and, before powering it up again I'm going to 
open it up and see if I need to clean out an accumulation of dust.

I'll provide some feedback later today.  (I also plan to mount both of my 
computers at desktop height (instead of on the floor) to minimize dust 
accumulation (unless the computer is pristine, which I doubt ;-)

I also fixed the quoting in the remainder of this post (i.e., the previous 
post) (the main message having been that I have at least 12 GB in this 
machine).

On Friday, May 10, 2019 09:22:26 AM rh kramer wrote:
> Aside: I'm not sure how this will appear as I am sending this from the
> google mail web client and I've tried to intersperse my reply within René's
> text.
> 
> On Fri, May 10, 2019 at 8:58 AM René J.V. Bertin <rjvbertin at gmail.com>
> 
> wrote:
> > The only reason for this that I can think of is that you are using a
> > machine which is severely limited in RAM and doesn't have enough swap
> > space either. KDevelop can indeed requirer oodles of RAM when parsing a
> > large project. Running under an older kernel may not help here.
> > 
> I have at least 12 GB on this machine (I might have 16 GB with 4 GB tied
> up in some ram drives) -- at the moment (before starting kdevelop) I have
> 10.3 GB available -- should I be concerned?  (Do you think I need to
> disable the overcommit?)  (I'll try to find / solve the scintilla namespace
> problem first and try fixing that, and if that doesn't work, I'll try
> disabling the overcommit.)
> 
> > If indeed you have little RAM it may help you to turn off overcommit with
> > the 2 commands below (in a script to be run as root). Basically that
> > means applications can no longer allocate more memory than is available
> > but will be killed when they try. I'd to this after you have logged in,
> > btw, but you can put it in /etc/rc.local too.
> > 
> > %> echo 80 > /proc/sys/vm/overcommit_ratio
> > %> echo 2 > /proc/sys/vm/overcommit_memory
> > 
> > R.


More information about the KDevelop mailing list