New version debugger issue.

Aleix Pol aleixpol at
Tue Jul 14 15:04:54 BST 2015

On Tue, Jul 14, 2015 at 12:54 PM, Leon Pollak <leonp at> wrote:
> Hello, all again.
> Thanks to Milian, I have the working kdevelop.
> Now I should like to return to the main issue: the new versions of kdevelop
> debugger does not work within my current environment, which is cross debugging
> of ARM based computer from PC running Fedora. My gdb is 7.7.
> 1. The first case was when I installed the FC21 and the new kdevelop. After
> installation I saw this MI error and nothing worked.
> I tried to recompile the kdevelop to old version and wasn't able to do this.
> Then I simply re-installed FC20 and worked with 4.5.2 till it came to the FC20
> update.
> 2. I did not noticed (and forgot, really) that FC20 upgrade installed the
> 4.7.1 version, which immediately stopped to debug with this MI error.
> Now, I had no chance but to downgrade...
> So:
> - Is this issue with the MI error known?
> - May it be the gdb-7.7 version I use?
> Thanks.
> --
> Leon
> _______________________________________________
> KDevelop mailing list
> KDevelop at

I'm using gdb 7.9 (from ArchLinux) and it works fine. I haven't had
any regressions in the past, even when I had 7.7. I'm unsure about the
nature of your issue, but it's probably related to ARM or to actually
using remote debugging (which I haven't so far).


More information about the KDevelop mailing list