New version debugger issue.

Leon Pollak leonp at
Tue Jul 14 14:56:11 BST 2015

Hi, Funkster...:-)

On Tuesday 14 July 2015 13:30:28 Funkster wrote:
> Hi Leon,
>    Now that you are able to compile (I gave up trying to satisfy all the
> requirements and simply returned to 4.7.0 using binary rpms), have you tried
As for satisfying - do you know about the 'devel' (For Fedora) versions of 
libraries required? I found it very frustrating the messages saying "Package 
XXX required", while actually it is XXX-devel required.
When I install 'devel' packages, it usually compiles ok.

> the latest KDevelop from head? I dare say it has other problems, but I'd be
> very interested to know if remote ARM debugging works.
I did not tried the 4.7.1 version - a lot of work, while I am in the dreadful 
lack of time.
Another issue is the ARM toolchain. I just found the crosstool generator, but 
did not studied it because of the same lack of time.

But my humble opinion is that gdb 7.7 version must be good enough!
>    There was talk on the mailing lists of GDB fixes in an earlier branch
> being merged back into the trunk, but I couldn't find any individual fixes
> to see if they were in 4.7.1 or not.
Previously kdevelop guys published the information about the minimal gdb 
version required. I did not see this info now, but again 7.7 (which one can 
find in CodeSourcery) seems to be good enough...:-)

>    Failing all that I guess we should diff the sources for 4.7.0 and 4.7.1
> to see what broke it, but that sounds like a lot of work to me.
I agree. Before that, I would be happy to hear this simple thing (gdb version 
required) from the kdevelop community...


More information about the KDevelop mailing list