KDevCustomMakeManager and KDevCMakeManager plugins not loading

Milian Wolff mail at milianw.de
Mon Dec 2 15:40:21 GMT 2013

On Monday 02 December 2013 10:07:12 Alvin Beach wrote:
> Hello,
> I upgrade KDevelop (now 4.5.2 - KDevPlatform 4.11.3) this morning to from
> the openSUSE 12.3 repo[1] and I am getting this error message when I load
> my custom makefile project:
>  "Could not load project management plugin KDevCustomMakeManager"
> That message is then followed by:
>  "project import plugin (KDevCustomMakeManager) does not support the
> IProjectFileManager interface."
> I get similar errors when I try to load a project that uses cmake. In this
> case, the errors refer to KDevCMakeManager.
> I ran kbuildsycoca4, but that didn't fix the problem.
> I tried creating a new session, however creating a new project doesn't seem
> to be available. I tried the "New Project" button on the "Sessoins" page in
> KDevelop, but it didn't do anything.
> I have also seemed to have lost the side and bottom panes/views (e.g.
> Classes, Project, Documentation, Build, etc.)
> Is there anything I can do or is this an issue with the repository's build?

No clue about OpenSuse, but this sounds like no plugins at all can be found. 

Can you run the following and paste its output somewhere online?

ktraderclient --servicetype KDevelop/Plugin

Especially interesting is the X-KDevelop-Version here, for 4.5.2 it should be 
15. So to make sure, just see whether this produces a different result:

ktraderclient --servicetype KDevelop/Plugin --constraint '[[X-KDevelop-
Version]] == "15"'

Also double check the stuff installed by your package manager, i.e. do 
something like:

find /usr/share -name "kdev*.desktop" | xargs grep X-KDevelop-Version

Milian Wolff
mail at milianw.de

More information about the KDevelop mailing list