KDevCustomMakeManager and KDevCMakeManager plugins not loading

Alvin Beach alvinbeach at gmail.com
Mon Dec 2 14:07:12 GMT 2013


I upgrade KDevelop (now 4.5.2 - KDevPlatform 4.11.3) this morning to from the openSUSE 12.3 repo[1]
and I am getting this error message when I load my custom makefile project:

 "Could not load project management plugin KDevCustomMakeManager"

That message is then followed by:

 "project import plugin (KDevCustomMakeManager) does not support the IProjectFileManager interface."

I get similar errors when I try to load a project that uses cmake. In this case, the errors refer to

I ran kbuildsycoca4, but that didn't fix the problem.

I tried creating a new session, however creating a new project doesn't seem to be available. I tried
the "New Project" button on the "Sessoins" page in KDevelop, but it didn't do anything.

I have also seemed to have lost the side and bottom panes/views (e.g. Classes, Project,
Documentation, Build, etc.)

Is there anything I can do or is this an issue with the repository's build?

[1] KDE Extra Repo for KDE Release 4.11



More information about the KDevelop mailing list