Back to 3.5.5

Leon Pollak leonp at plris.com
Tue Jun 1 11:17:42 UTC 2010


Meanwhile, I searched the internet and found some hints. 
I restored my former .kde directory from old backups and put it into 
~/oldhomekde/ directory. 
Then I modified the script line to
export KDEHOME=~/oldhomekde/
and run the script.

Now, the error message was the same, but kdevelop3.5.5 started with normal 
fonts and with the same error message.
BUT THERE WERE ALL MENUS!!!

Now, when I choose Project->Open and give it my old 3.5.5. project, I receive 
the message:
No language plugin for C++ found.
And the project does not open.

I checked, as advised, the libdb stuff looks OK.

Please, help!!!!



On Sunday May 30 2010, Andreas Pakulat wrote:
> It works the same way, get kdelibs-dev package from KDE3 and build
> kdevelop3 into a directory in your home. Then when you want to start it
> make sure to set KDEDIRS to point to that directory and KDEHOME to
> something else than the .kde-dir used by your KDE4 installation. Now run
> kbuildsycoca (no 4 in that name) and then start kdevelop.
> 
Andreas,

Please, excuse my stupidity... It is not my area at all...
-------------
I made the following script:

export KDEDIRS=~/kdevelop-3.5.5:$KDEDIRS
export KDEHOME=~/kdevelop-3.5.5
kbuildsycoca
kdevelop &
-----------
And when I run it, I receive:

Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
kbuildsycoca running...
Reusing existing ksycoca
--------
And kdevelop starts with the error message:

Unable to find plugins, KDevelop will not work properly.
Please make sure that KDevelop is installed in your KDE directory; otherwise, 
you have to add KDevelop's installation path to the environment variable 
KDEDIRS and run kbuildsycoca. Restart KDevelop afterwards.
Example for BASH users:
export KDEDIRS=/path/to/kdevelop:$KDEDIRS && kbuildsycoca
===============
Please, help!
-- 
Leon





More information about the KDevelop mailing list