Unknown CMake command "kdevplatform_add_app_templates"

VestniK vestnik at ngs.ru
Wed May 6 19:51:42 UTC 2009


Hello

I'm trying to compile kdevelop on ubuntu 9.04 following this manual: 
http://www.kdevelop.org/mediawiki/index.php/KDevelop_4/compiling

1 I've checked out from svn, compiled and installed the kdeplatform package 
using installation path in my home.
2 I've added kdeplatform installation path to the KDEDIRS variable:
$ echo $KDEDIRS
/home/vestnik/Development/KDE/builds:/usr

When I try to run cmake for kdevelop (using the following command I got the 
following output:
$ cmake -DCMAKE_PREFIX_PATH=/home/vestnik/Development/KDE/builds -
DCMAKE_INSTALL_PREFIX=/home/vestnik/Development/KDE/builds ../                                               
-- Found Qt-Version 4.5.0 (using /usr/bin/qmake)                                                                   
-- Found X11: /usr/lib/libX11.so                                                                                   
-- Adding /home/vestnik/Development/KDE/builds/share/apps/cmake/modules to 
CMAKE_MODULE_PATH                       
-- Phonon Version: 4.3.0                                                                                           
-- Found KDE 4.2 include dir: /usr/include                                                                         
-- Found KDE 4.2 library dir: /usr/lib                                                                             
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler                                         
-- Found automoc4: /usr/bin/automoc4                                                                               
-- Assuming existence of the generated parser files for the parser                                                 
CMake Error at app_templates/CMakeLists.txt:9 
(kdevplatform_add_app_templates):                                    
  Unknown CMake command "kdevplatform_add_app_templates".                                                          


-- Configuring incomplete, errors occurred!

I've tried to search for the kdevplatform_add_app_templates command in *.cmake 
files in my kdevplatform installation path and found that it's defined in the 
file: 
/home/vestnik/Development/KDE/builds/lib/kdevplatform/KDevPlatformMacros.cmake

I've tried to create simlink pointing on this file in the 
/home/vestnik/Development/KDE/builds/share/apps/cmake/modules directory since 
according to the cmake output this dir is addded to the CMAKE_MODULE_PATH 
(I've no experience of working with CMake but I thought it might help) but 
still get the same error.

I've looked through this mail list archive from January 2009 to but didn't find 
any usefull information. I've tried to search using google and find this page:
http://milianw.de/blog/building-kdevplatform-kdevelop-and-the-php-plugin-from-
svn
The same error is mentioned in the comments and the only suggestion is to use 
some third party environment configuration scripts. I didn't try them yet but I 
wonder where am I making a mistake?

--
  Sergey Vidyuk
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kdevelop/attachments/20090507/66dd513d/attachment.sig>


More information about the KDevelop mailing list