Crash on startup

Andreas Pakulat apaku at gmx.de
Sun Jan 27 17:22:56 UTC 2008


On 27.01.08 16:30:45, Leon Pollak wrote:
> On Sunday, 27 בJanuary 2008, Andreas Pakulat wrote:
> > On 27.01.08 11:12:49, Leon Pollak wrote:
> > > The story continues - I can not load a project. Kdevelop crashes on
> > > project opening (starts OK when no project is opened).
> > > As I was recommended previously (thanks!), I deleted all *.pcs files, but
> > > this time this does not help. Already no these files at all, but...
> >
> > Its still the same backtrace and thus the same problem, did you also
> > remove the .pcs files under $HOME/.kde/share/apps/kdevcppsupport/pcs?
> > Also in your project directory?
> Yes, there are no these files at all.
> And they are no more recreated for some reason.
> I mean, that after deletion, even when the project started, these files were 
> not recreated. Is it correct?

If you start kdevelop without project, then load a project, let it parse
and close the project (not kdevelop) there should be a file called
<project>.kdevelop.pcs in the project directory. Of course if KDevelop
crashes before that it won't create the file.

The PCS files in your $HOME/.kde are from the class stores you created
under Project Options->C++.

> > If all that doesn't help I can only suggest to build Berkley DB and
> > KDevelop from source (the latter from SVN), apparently some distro's
> > patch kdevelop or berkley db just too much.
> I am not sure that I understand what you mean:
> 
> - the kdevelop itself is that from kdevelop.org site I downloaded. I use only 
> these rpm's.

Good, that rules out one failure point.

> - Yes, the db is that of distro FC8. I tried to install the last kdevelop 
> 3.5.0-28.1, but did not succeeded:
> Error: Missing Dependency: db >= 4.1 is needed by package kdevelop3

I might be mistaken, but kdevelop3 is not the package name. Its just
"kdevelop". Of course I could be wrong here, I'm not using a rpm-based
distro...

Andreas

-- 
Your lucky number has been disconnected.




More information about the KDevelop mailing list