Trunk version doesn't load plugins?

Andreas Pakulat apaku at
Thu Jun 26 19:45:29 UTC 2014


On Thu, Jun 26, 2014 at 7:15 PM, Aleksey Midenkov <midenok at> wrote:

> On Thu, Jun 26, 2014 at 9:00 PM, Sven Brauch <svenbrauch at>
> wrote:
> > On Thursday 26 June 2014 20:54:59 Aleksey Midenkov wrote:
> >> F.ex. start system stable kdevelop and debug development branch under
> >> it. As I understand sycoca allows only one version of plugins at a
> >> time?
> > Yes, but you have various ways to achieve what you want despite that, the
> > simplest being just changing $KDEDIRS and re-running kbuildsycoca after
> you
> > started your stable KDevelop. But fancier setups which use two completely
> > different environments are also possible if you set the right env vars.
> Yes, I understand all the possibilities. And this means whole Circue
> du Soleil around clumsy sycoca. I would prefer cunning patch...

Well, some of the smartest people in KDE have tried to do that and were not
able to get it done as far as I understood from previous mails. But you're
of course welcome to look into the sycoca codebase.

Until then, you could also just consider to use the development version for
hacking on it. I believe thats what most/all kdevelop devs still do and
what worked fine for me ever since kdev 4.0 was able to open a C++ file
back in 2005 or so. Sometimes it crashed more often, but that also meant
those crashes where fixed quicker because they were disturbing my normal

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the KDevelop-devel mailing list