Review Request: (code deduplication) Add class OutputExecuteJob as a common base for all output jobs which start processes

Ivan Shapovalov intelfx100 at
Wed Sep 19 16:36:39 UTC 2012

This is an automatically generated e-mail. To reply, visit:

(Updated Sept. 19, 2012, 4:36 p.m.)

Review request for KDevelop.


Updated patch from comments.

- Added separate error messages for builder jobs (using a new property IsBuilderHint, which is supposed to be set by builder jobs)
- Now using KShell:joinArgs()
- Fixed timeouts and messages in OutputExecuteJob::doKill() // Left both terminate() and kill(), timeout for them is now 1000 msecs - any further suggestions?
- Now clearing user-set LC_ALL in process environment if portable messages are required for it // maybe rename it to LANG?
- Fixed spelling in process error messages + they now specify the executable name
- Improved working directory checking (it will now create a working directory by default if it does not exist)
- Added Q_DECLARE_OPERATORS_FOR_FLAGS() for JobProperties.


This class is going to be used instead of OutputJob as a common base for all such jobs which start processes (esp., builder jobs).

There are separate patches for make builder, cmake job and ninja builder.

Diffs (updated)

  outputview/outputexecutejob.cpp PRE-CREATION 
  outputview/CMakeLists.txt 3dced4c 
  outputview/outputexecutejob.h PRE-CREATION 



Existing unit-tests and manual testing (couple of days).


Ivan Shapovalov

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the KDevelop-devel mailing list