Patches for git plugin related reviews

Milian Wolff mail at
Mon Oct 17 23:43:46 UTC 2011

On Monday 17 October 2011 10:14:50 Sergey Vidyuk wrote:
> Hello
> Patches for reviews
> are attached. Patch for 102857 is modified following the last suggestion
> from Milian.

If noone is beating me to it, I'll push them tomorrow.

> I've also uploaded modified version into reviewboard. I'm
> unsure if it's good idea to have cpp file for implementation of one empty
> function.

It's virtual and hence cannot be inlined anyways. Furthermore inlined 
functions are more of a pita than anything else in such non-performance-
critical sections. So as the release-dude I want new KDevelop code to only use 
inline code in sections where it's actually required performance wise. 
Everything else is just lazy :P

> Actually I'm unsure if it's good idea to have non-pure virtual
> function in an interface. If needed I can move implementation back to
> header or into plugins.

I simply find it tedious to implement the empty {/* do nothing*/} routine in 
every plugin. This is a pure "nice-to-have" feature after all, and providing 
such an empty implementation does not hurt anyone - quite the contrary.

Otoh functions that *must* be properly implemented should be pure-virtual, I 
agree. Not the case here though.


Milian Wolff
mail at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the KDevelop-devel mailing list