Pointer-To-Member?

Milian Wolff mail at milianw.de
Sat Feb 5 17:39:17 UTC 2011


floris, 05.02.2011:
> On Thu, 2011-02-03 at 21:04 +0100, Milian Wolff wrote:
> > floris, 03.02.2011:
> > > On Sun, 2011-01-30 at 02:02 +0100, Milian Wolff wrote:
> > > > Hello Floris,
> > > > 
> > > > I don't want to see your patch get bitrotted, so want to nag you
> > > > again: What is the status of it? You haven't responded to my
> > > > questions on the review request [1].
> > > > 
> > > > To me your patch looks quite good, but without unit tests it cannot
> > > > get merged. If you need help with writing them, please tell us so.
> > > > Maybe someone (OliJG? Drisenberg? PovAddict?) could help writing
> > > > them?
> > > > 
> > > > [1]: http://git.reviewboard.kde.org/r/100239/
> > > > 
> > > > Bye
> > > 
> > > i put my branch on gitorious. I doesn't pass all the tests and has some
> > > unrelated patches though. I will remove those patches when the branch
> > > passes all the tests again. it has a duchaintest now, which it fails...
> > > 
> > > http://gitorious.org/kdev-p2m/kdev-p2m
> > 
> > I hope to investigate over the weekend, but please send all mails to our
> > developer ML in future so others can chime in.
> > 
> > thanks, take care
> 
> i have the unit test working now, some other tests are failing but i'm
> quite sure it's not my fault (astyletest for example). i wanted to put
> my patches back on reviewboard, but there are three patches now, and i
> don't seem to be able to post three patches in one reviewrequest, so i'm
> qoing to attach them to this mail.

only run the tests in languages/cpp but yeah, they all seem to pass. good 
work.

> as far as i can tell, they should apply fine on master.

they do.

> the patches include mostly changes to the parser and the typebuilder
> stuff to make it recognize pointer to member types. it also includes a
> parser and a duchaintest (both passing) and an edit to the codegen (so
> it generates correctly).

before inclusion, I would like to ask you to clean the patches up some more. 
esp. things like commenting out return or LOCKDUCHAIN things look ugly. Remove 
statements, if they are obsoleted.

Also, please rename PtrToMemberType::ClassType() to 
PtrToMemberType::classType() to stay consistent with our usual API naming 
convention.

And, if possible, remove the trailing whitespaces you added in some places, 
"git diff --color" shows them quite nicely. Lowprio though ;-)

> I hope that attachments are okay.

sure. but once they are mergeable, please provide them in "git format-patch" 
style, so I can "git am" then. If noone objects (David?) I'm going to merge 
them if you do the cleanups I mentioned above.

bye, and thanks for your contribution
-- 
Milian Wolff
mail at milianw.de
http://milianw.de
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kdevelop-devel/attachments/20110205/e09c2681/attachment.sig>


More information about the KDevelop-devel mailing list