[RFC] s/Part/Plugin/

Andreas Pakulat apaku at gmx.de
Fri Nov 23 09:59:08 UTC 2007

On 23.11.07 09:37:03, David Nolden wrote:
> On Thursday 22 November 2007 21:44:44 Andreas Pakulat wrote:
> > Hi,
> >
> > there are still quite some plugins in the platform and kdevelop that are
> > named "XXXPart". I'd like to change that to XXXPlugin as thats more
> > correct and won't confuse anybody - anybody who knows KParts might
> > think there's a relation between those plugins and KPart.  Another
> > reason is simple consistency.
> >
> > Are there any objections against doing so? (this will include
> > classnames, member names and filenames)
> >
> > Andreas
> No objections from me, except that it might be quite some effort, without much 
> benefit. :)

The effort is really small, as far as I can see: Ctrl+Shift+R in
KDevelop, let it replace _part with plugin, Part with Plugin and a few
places with s/part/plugin. Rename a few files as well. Changing the
problemreporter took me less than a minute ;)


Abandon the search for Truth; settle for a good fantasy.

More information about the KDevelop-devel mailing list