[Bug 83445] GDB does not work

Scott Shandler shandles at mail.med.upenn.edu
Thu Jun 17 23:50:03 UTC 2004

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From shandles mail med upenn edu  2004-06-17 15:21 -------
Whenever I run the debugger inside of kdevelop, the tty number changes.  I 
figure that the tty number has to do with the shell that it sometimes 
launches.  I have tried it with and without launching a new terminal window, 
and I still get the shared library error.  I have changed both my version of 
kdevelop from 2.1.3 to 3.0.3 and my version of redhat from 8.0 to fedora core 
2 and I am just not sure where the problem is.  However, when I run the same 
commands that kdevelop does, outside of kdevelop debugging window, it fails 
with the tty line and works without it.  


Scott Shandler
Graduate Student
Biochemistry & Molecular BioPhysics
University of Pennsylvania
shandles mail med upenn edu

Quoting John Birch <jbb kdevelop org>:

> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
> http://bugs.kde.org/show_bug.cgi?id=83445      
> ------- Additional Comments From jbb kdevelop org  2004-06-17 09:43 -------
> Scott,
> You said it didn´t work with ¨tty /dev/pts/57¨? Was the 57 correct? ie you
> typed tty on a terminal and replaced 57 with whatever it supplies?
> The tty code has worked since 1999 so I´d not be suprised if it stopped
> working on a major change of the system. It´s possible it needs
> refreshing...
> .. or has this bug skewed off into a libtool problem now?
> jbb

More information about the KDevelop-devel mailing list