[Bug 83445] GDB does not work

Roger Larsson roger.larsson at norran.net
Fri Jun 18 01:28:08 UTC 2004

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From roger.larsson norran net  2004-06-18 01:27 -------
> Whenever I run the debugger inside of kdevelop, the tty number changes.  I 
> figure that the tty number has to do with the shell that it sometimes 
> launches.

I am pretty sure this is the case.

> I have tried it with and without launching a new terminal window, 
> and I still get the shared library error.

Have you got the _same_ error with all versions (kdevelop, system)?
Do you get the same error if you generate a new project from scratch?
(using the wizard)

> However, when I run the same 
> commands that kdevelop does, outside of kdevelop debugging window, it fails 
> with the tty line and works without it.   
* Do you use _identical_ lines - including "sh" and ".../libtool" or do you start from gdb?
"/bin/sh -c /home/shandles/projects/tiger/libtool /usr/bin/gdb /home/shandles/projects/tiger/tiger/tiger -fullname -nx -quiet"

* Do you get the _identical_ works/non works result? Or do you get different errors?

* You get "(no debugging symbols found)... " before the tty command (so that cant  be blamed on the tty command). Why? Does not tiger contain debug info? Or does it try to debug gdb itself?

More information about the KDevelop-devel mailing list