[kdepim-users] Kontact/Calendar bug?

r bartlett techwritebos at yahoo.com
Sat Oct 17 18:58:49 BST 2009

Hi Anne, thanks so much for the helpful hints...see below for more comments:

> > No idea if this will help, but this problem is very repeatable:
> >
> > 1.  I tried running Korganizer by itself from a terminal and got a lot of
> >  the following:
> >
> > QPixmap::setMask: Cannot set mask while pixmap is being painted on
> > QPixmap::setMask: Cannot set mask while pixmap is being painted on
> I'd ignore those.  You see lots of similar messages when starting an app
> from a terminal.  Occasionally they are useful when troubleshooting, but I
> think it's often a case of the developer not requiring a function so not
> setting it up.  I very much doubt that these have any bearing on your
> problem.
Okay.  I just thought perhaps that meant something.

> > 2.  It occurs whether one is in Month view or Day view.  As soon as
> > "Apply" is clicked after editing a pre-exisiting Event, it
> > disappears...However, it is still visible in the Event view pane on the
> > side. 3.  If you click on a different day, then return, the Event view
> > pane also no longer has any record of the event.
> >
> > 4.  Quit out, come back...Presto!!!  The Amazing Disappearing Event is
> >  back, with all your freshest changes!
> I wonder if some sort of corruption set in when you used Import, rather
> than just copy over.  If I were you I'd try renaming the calendar you have
> there, copying over your old one, and pointing the default configuration to
> that one. If you have more recent entries you need to add to it, you can
> always add the dodgy one as a separate calendar, temporarily.
I've actually done it 2 ways and there was the same problem.  First I was working with the entire old .kde directory copied over new.  Then I wiped that and started over by Importing whatever I could import.  Both ways had the same problem.  However, that said, the calendar was the same because I did a lot of work on it (planning an entire month long trip) and I don't want to lose that work and all the changes.  I do have an older version of the calendar that doesn't have all these changes and I could import (or copy) that over and see if the problem still occurs.  But I'm loathe to lose all those changes.

I merged the default calendar with the old one.  Perhaps that caused problems?  I'm thinking if perhaps I tried it with just the default calendar displayed side by side with the other one?

Or...as you say, maybe the trick is to copy the file again directly rather than import it.

> > Sigh....I even tried it remotely using VNC over an ssh tunnel and had the
> >  same thing occur.
> It has to be something fairly straightforward, I think, so don't give up.
> We'll get it sorted for you.  I've been using kmail, kaddressbook and
> korganizer for more than 7 years.  It's certainly not usual to have this
> sort of problem, but few problems are without a solution.
> Anne

I've been using Kmail perhaps longer than you, by the way...since RedHat 6.1 (2000?  2001?)  The difference is that I'm not a computer person and you are.  (^_^)  So whereas I fumble along the best I can when things need tweaking, I rarely know what I'm doing and frequently make them worse.  Something I did this time around or some legacy weirdness that I did that's carrying over from the old file may be what's causing it.

As always, thanks for your helpful hints and ideas!

New to KDE4? - get help from http://userbase.kde.org
Just found a cool new feature?  Add it to UserBase

KDE PIM users mailing list
kdepim-users at kde.org

More information about the kdepim-users mailing list