Sound problems again...

Jogchum Reitsma j.reitsma at
Tue Aug 12 19:38:41 BST 2014

Hi all,

While I love my opensuse/kde systems dearly, sound has always been a 
hassle here. Sometimes it works fine, sometimes it doesn't work at all, 
sometimes it works half.

At the moment, I have a desktop running opensuse 13.1/KDE 4.11.5 on 
which youtube sound through Firefox works, but apparently nothing else. 
CD-playing, local music files, other-than-youtube movies trough Firefox, 
(e.g. do not work.

In all these cases (including the one where sound is indeed reproduced!) 
kmix says there is no sound stream being played.

The sound card is a Xonar STX, which indeed is granted a tab in kmix. 
But the menu "Configuration->Sound configuration" shows no hardware at 
all, only the PulsAudio server. On the other hand, 
"Configuration->Select main channel" says the current mixer is Xonar, 
and the channel representing the main volume is the Master of the Xonar STX.

I tried to remove/re-install the Xonar with Yast (the main configuration 
tool of opensuse), but no luck. Testing the card from within Yast works 
fine, though.

Frustrating is that is *has* worked a certain time, until some upgrade 
(i keep the system in sync with the 13.1 repos for opensuse).

Anyone any idea?

(BTW, I also have a laptop running opensuse Factory, which behaves just 
the opposite: everything works, except for Firefox sound... But that's 
something for another thread.)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list