Plasma "upside down" ...

Hans Muecke kde at
Sun Jul 15 12:04:59 BST 2012

Am 14.07.2012 21:37, schrieb Duncan:

>> I might have been a bit incorrect here, since I didn't have any
>> applications running at that moment, when I first ran into this problem.
>> I just started from scratch again ... deleted the plasma* files in my
>> home directory, rebooted and this time took care and chose the
>> plasma-desktop session and not the protected one (when I say protected
>> ... I can't think of another word for "abgesichert" which is also used
>> when a windows crashes and gives one the choice of starting windows and
>> starting a protected windows ... I think you get the idea).
> Oh! <the light dawns>  Safe mode (MS side), aka failsafe mode (what I've 
> seen it called on Linux)!

Merde alors! Failsafe ... I remember that from my SuSE past ... :-)
> It's beginning to make more sense, now!
>> Started with setting up the desktop and tried to activate desktop
>> effects via schift-alt-f12 and bamm! Everything upside down again, the
>> screen flipped again, as I could tell from the control bar on the left
>> side of the screen and the open system-settings window. Funny "side
>> effect" .. while visually flipped I still had to click in the areas,
>> where all the buttons are supposed to be (hope you understand what I am
>> talking about ... :-) )
> As Martin B says, that's interesting.  See below...
>> Since you mentioned OpenGL I chchanged the composite type to Xrender and
>> I don't the problem there (means I can activate effects without the
>> flipping of the screen).
> OK, definitely making sense now.  Failsafe mode would probably disable 
> most of that, and when you returned to normal mode and tried to enable 
> effects, that kicked in the OpenGL, and it's OpenGL that's the problem, 
> confirmed by not seeing it in XRender mode.
>>> Miroslaw's idea is obviously that it's either an xorg config issue, or
>>> indirectly an xorg config issue, thru kde's display settings.
> ... And now he appears to have been closer than I was, initially.
>>> What I /suspect/ you mean is plasma's  "lock widgets" / "unlock
>>> widgets" mode toggle
>> Nope. I was talking about checking "enable desktop effects at startup".
>> I have it disabled for now.
> OK, that fits the new, more detail, picture of the situation.
>> Nope ... no problem with the widgets and in fact I have never seen this
>> defaulted behaviour. On my end KDE starts with the last state (means
>> "locked" when previously locked and "unlocked, whern previously
>> unlocked).
> Hmm...  I wonder if that's a distro patch?  Could be.  But regardless, 
> it's a tangent since that's not what you were referring to.
>>> Honestly, I'm not exactly sure where to take it from there, but
>>> confirming those three things will be a start.
> Good thing too, as I had guessed quite wrong.  But...
>>> I /have/ seen plasma (JUST plasma, nothing else) get confused and
>>> screwed up display-wise[,] between having OpenGL on and having it off
> ... While it was a bit of a shot in the dark, that OpenGL vs. XRender bit 
> seems to be a major clue.  Combine that with the visual vertical 
> mirroring... that X/KDE has no clue is happening so your input has to be 
> as if it's NOT mirrored, and Martin's on exactly the right track.  He 
> asked about your graphics and drivers, and you replied nVidia, which he 
> then suggests changing.
> I'll second that.  Either try the nouveau driver or try a different 

Checked ... the GT545 is not listed there at all.

> version of the nVidia driver.  It could also be that some nVidia driver 
> config option will disable whatever's triggering the problem, but I'd 

I have no idea ... it worked ok for quite some time now and I never
changed the initial configuration and the last re-installation of the
driver because of a kernel update was some time ago. It simply came out
of nowhere, so I think it came with some security update I did.

> have no clue what option, since nVidia graphics are on my black list and 
> have been for a decade, where they'll stay until nVidia gets an attitude 
> adjustment and begins cooperating at least enough to provide specs to the 
> freedomware folks, instead of forcing the reverse-engineer.  (So I don't 
> even know how relatively old/new that GeForce GT 545 hardware you quoted 

It must have come to the market sometimes in the first half of 2011 and
is marketed only as OEM for computer manufacturers (machine is a Lenovo).

> actually is.  However, for older hardware, the nouveau driver is often on 
> par with the nVidia driver, even if the devs /were/ forced to reverse 
> engineer the hardware to do it!)

I tend more to using a different version of the nVidia driver.
Originally the nouveau driver was installed with Kubuntu, but it never
could bring up a decent resolution.
> I wonder if perhaps you pulled in a driver update, thus the problem?  Do 
> you have a log you can look at to see if the nVidia driver, and/or xorg-
> server, got updated recently?  If so, you can try simply downgrading back 

<head-on-the-desk-drop> Aaaargh, xorg-server got updated

> to the previous version.  Of course, keep in mind that the upgrade might 
> have had security implications as well, so it might be worth checking 
> that.

Will do ... thanks for pointing at some solutions!

Talk to you later ... Hans (54 to go)

2012/07/15 10:20
EDDS 151020Z 28018G28KT 9999 -SHRA FEW037 BKN045 15/10 Q1016 TEMPO SHRA

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list