Plasma "upside down" ...

Duncan 1i5t5.duncan at
Sun Jul 15 03:37:10 BST 2012

Hans Muecke posted on Sat, 14 Jul 2012 06:41:54 -0500 as excerpted:

> Am 13.07.2012 18:51, schrieb Duncan:
> Hi Duncan,
>> Hans Muecke posted on Fri, 13 Jul 2012 12:44:04 -0500 as excerpted:
>>> Howdy folks,
>>> Ran into a strange problem ...
>>> Kubuntu 12.04LTS/KDE4.8.4 ...
>>> For whatever reason my plasma desktop crashed yesterday. Couldn't get
>>> it to come up again, so I deleted all the plasma files in the home
>>> directory to start from scratch.
>>> I must have done that in the "protected mode" unknowingly ... since
>>> today - when trying to change one of the desktop effects - I was told
>>> that I was running protected mode and should switch to the "normal"
>>> plasma desktop.
>>> Did as requested and ended up with an "upside down" desktop. Visually
>>> everything is upside down, but buttons still seem to be where they are
>>> supposed to be on the desktop (screenshots: and
>>> ). Everything looks fine in protected mode ...
>>> minus effects that is.

>> I guess you're translating from (looks like German maybe?)

> I am doing this from german ...

OK.  That explains some of it...

>> the terms don't quite match what I'm used to. 
>> So let's first confirm that we're talking about the same thing. =:^)
>> 1) The thread title says plasma, and the pix look like plasma-desktop
>> only.  So the first thing is to confirm, it's plasma ONLY that's
>> affected, correct?  All other apps look normal?
> I might have been a bit incorrect here, since I didn't have any
> applications running at that moment, when I first ran into this problem.
> I just started from scratch again ... deleted the plasma* files in my
> home directory, rebooted and this time took care and chose the
> plasma-desktop session and not the protected one (when I say protected
> ... I can't think of another word for "abgesichert" which is also used
> when a windows crashes and gives one the choice of starting windows and
> starting a protected windows ... I think you get the idea).

Oh! <the light dawns>  Safe mode (MS side), aka failsafe mode (what I've 
seen it called on Linux)!

It's beginning to make more sense, now!

> Started with setting up the desktop and tried to activate desktop
> effects via schift-alt-f12 and bamm! Everything upside down again, the
> screen flipped again, as I could tell from the control bar on the left
> side of the screen and the open system-settings window. Funny "side
> effect" .. while visually flipped I still had to click in the areas,
> where all the buttons are supposed to be (hope you understand what I am
> talking about ... :-) )

As Martin B says, that's interesting.  See below...

> Since you mentioned OpenGL I chchanged the composite type to Xrender and
> I don't the problem there (means I can activate effects without the
> flipping of the screen).

OK, definitely making sense now.  Failsafe mode would probably disable 
most of that, and when you returned to normal mode and tried to enable 
effects, that kicked in the OpenGL, and it's OpenGL that's the problem, 
confirmed by not seeing it in XRender mode.

>> Miroslaw's idea is obviously that it's either an xorg config issue, or
>> indirectly an xorg config issue, thru kde's display settings.

... And now he appears to have been closer than I was, initially.

>> What I /suspect/ you mean is plasma's  "lock widgets" / "unlock
>> widgets" mode toggle

> Nope. I was talking about checking "enable desktop effects at startup".
> I have it disabled for now.

OK, that fits the new, more detail, picture of the situation.

> Nope ... no problem with the widgets and in fact I have never seen this
> defaulted behaviour. On my end KDE starts with the last state (means
> "locked" when previously locked and "unlocked, whern previously
> unlocked).

Hmm...  I wonder if that's a distro patch?  Could be.  But regardless, 
it's a tangent since that's not what you were referring to.

>> Honestly, I'm not exactly sure where to take it from there, but
>> confirming those three things will be a start.

Good thing too, as I had guessed quite wrong.  But...

>> I /have/ seen plasma (JUST plasma, nothing else) get confused and
>> screwed up display-wise[,] between having OpenGL on and having it off

... While it was a bit of a shot in the dark, that OpenGL vs. XRender bit 
seems to be a major clue.  Combine that with the visual vertical 
mirroring... that X/KDE has no clue is happening so your input has to be 
as if it's NOT mirrored, and Martin's on exactly the right track.  He 
asked about your graphics and drivers, and you replied nVidia, which he 
then suggests changing.

I'll second that.  Either try the nouveau driver or try a different 
version of the nVidia driver.  It could also be that some nVidia driver 
config option will disable whatever's triggering the problem, but I'd 
have no clue what option, since nVidia graphics are on my black list and 
have been for a decade, where they'll stay until nVidia gets an attitude 
adjustment and begins cooperating at least enough to provide specs to the 
freedomware folks, instead of forcing the reverse-engineer.  (So I don't 
even know how relatively old/new that GeForce GT 545 hardware you quoted 
actually is.  However, for older hardware, the nouveau driver is often on 
par with the nVidia driver, even if the devs /were/ forced to reverse 
engineer the hardware to do it!)

I wonder if perhaps you pulled in a driver update, thus the problem?  Do 
you have a log you can look at to see if the nVidia driver, and/or xorg-
server, got updated recently?  If so, you can try simply downgrading back 
to the previous version.  Of course, keep in mind that the upgrade might 
have had security implications as well, so it might be worth checking 

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list