Building DBusMenu-Qt

Duncan 1i5t5.duncan at
Mon Jun 20 22:49:06 BST 2011

David Doria posted on Mon, 20 Jun 2011 15:18:59 -0400 as excerpted:

>> OK, try setting/exporting QMAKESPEC

> Great, that worked (I did need the subdir:
> /home/ddoria/bin/qt4/mkspecs/linux-g++-64)!
> Since then, I have been able to build automoc and phonon.

Good, you're getting into kde-recognizable technologies, now. =:^)

> Now again trying to build kdelibs, I am getting:
>  WARNING: No valid KAuth backends will be built. The library will not
> work properly unless compiled with a working backend
> It seems more like an error than a warning, because after running cmake
> configure several times I still don't get the option to 'generate'.
> It looks like I may need to build polkit? When trying to do that, my
> autoconf was too old! I built autoconf, and then when I configured
> polkit, it said I am missing gio2.0. I can't find where to download gio
> source - can you please point me to it?

Based on the dependencies here, you should be able to specify that you do 
NOT want polkit support, since Gentoo has it as a USE flag which means 
the dependency is optional.  Let me see how the build specifies that it 
wants it or not...

$(cmake-utils_use_with policykit PolkitQt-1)

Translating the gentoo eclass shorthand...

cmake-utils_use_with <USE flag> [flag name]
    `cmake-utils_use_with foo FOO` echoes -DWITH_FOO=ON if foo is enabled
    and -DWITH_FOO=OFF if it is disabled.

(That's from the gentoo cmake-utils.eclass manpage, auto-generated from 
in-eclass documentation.)

So -DWITH_PolkitQt-1=OFF fed to the ./configure step, should disable that 
dependency.  (You can probably run ./configure --help to get a listing of 
this and other options you can feed to configure.  Might come in handy 
for other dependencies...)

As for gio2.0, I don't see a direct dependency of that name, but based on 
some comments on plugin packages for it, I /believe/ it's part of glib.  
So you apparently need a newer glib.  2.28.8 is what I have installed, 
2.28.6 is also available in gentoo, as well as the old glib-1.2.10 for 
those apps still using glib-1.  The polkit-0.101 ebuild says it needs 
>=glib-2.28, with the gentoo changelog saying 2.28.0 was introduced in 
February.  (Note that if you build a new glib, you'll probably need to 
rebuild dbus-glib too, as it'll break with a new glib.)

But depending on why you are building kdelibs (I thought I saw that you 
wanted it for kdevelop, but I can't seem to find it now), if you don't 
think you'll need the auth framework, it's probably easiest to simply 
disable that... at the cost of possibly needing to go back and enable it 
because something doesn't work, later.  If you're building all of kde, 
I'd definitely recommend keeping it enabled, but if you're just doing it 
for a couple packages, that aren't likely to need superuser auth or the 
like, you can probably get by without it.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list