KDEPIM 4.6 prob^Wimpressions

Alex Schuster wonko at wonkology.org
Sat Jul 23 21:11:20 BST 2011

I wrote:

> Removing .kde4 now. Let's see what happens.

I'm back. I removed the whole .kde4 directory, and copied back my
Akregator and Kopete settings only. First I forgot to also delete Akonadi's
settings. And when I did so, I only deleted .local/share/akonadi, but
forgot .config/akonadi, so I wondered why my Akonadi ressources were
still in place. But finally it was gone, and created Akonadi stuff from
scratch, too.

I hope things will be better now. Some things that happened while
configuring the desktop:

Systemsettings -> Password and User access: I could make any changes here, 
getting a 'permission denied' error. Later, it was working.

Suddenly my desktop folder view plasmoid vanished. Oh dear. It looks
like it still is in my plasma-desktop-appletsrc file, so I already have
more in there than I should. This should be the entry:



I removed those entries, but on the next login every desktop showed the 
plasmoids of the fist one.

When I tried to add the 'Simple CU and System Viewer' plasmoid I
downloaded, plasma froze, and I had to kill and restart plasma-desktop.
Happened also with another plasmoid which I do not remember now.

I uninstalled the 'Kood Morning' plasmoid I also downloaded, because I
confused it with another one I really wanted. I de-installed by
choosing 'Add Widgets' and then right-clicking on the plasmoid. Then I forgot 
about this, so when I wanted to install other plasmoids and the plasmoid 
download dialog was still open with the Kood Morning plasmoid, I klicked the 
'Deinstall' button. Again, plasma froze and had to be killed.

When restarting plasma-desktop, some folderviews that I just placed where I 
like them to be lost their position, I arranged them four times until they now 
are correct when I log in.

Some kde4init process sometimes crashes no long after login, I had this 

Konqueror shows files in my home directory when starting, although I told it 
so start with a blank page. Tried to reproduce this now, and got a page 
telling me the action could not be done, protocol could not be initialized, 
technical reason: process could not be started. I switched the application 
language to English, and now it works. Switched back to German, works, too. 
Oh, and it was the starter (in the quickstart plasmoid) that was wrong, when I 
start Konqueror via Krunner, it is as it should be.

My TV-Browser window was gone, and there was no icon in the tray. The java 
process was still running though. Killed and restarted.

The system was running at 100% for the whole night, nepomukservices was using 
70% of one of my two cores, accumulating nine hours of CPU time. virtuoso_t 
consumed around 45%. Strigi is disabled. Logging out took 1-2 minutes, of 
course also plasma crashed.
Nepomuk kept doing stuff even after logout, so I killed it. It did not start 
again then, and I got a notification that nepomuk indexing has been disabled. 
or something, the notification button on the systray does not react, so I 
cannot look up the exact error. When I run the Akonadi selftest, there is one 
error, Nepomuk service not registered a D-Bus. But at least it doesn't hog 
resources now.

Some minor annoyances:

The NEdit find+replace dialog vanished when I accidentally minimized it.
It was not in the list of minimized windows in the panel, but I could
make it show up again by using the desktop effect which shows all
running applications.

There are some configuration dialogs (desktop effects, KMail -> email editor), 
that ask me whether to apply changes, even if I made none.

Kontact complains at system start it is already running. This was a bug I had 
for a year or so, but recently it no longer happened. Looks like the bug is 

KNode shows HUUUUGE icons again, bug #266129, no big deal. Dragging a favicon 
from Konqueror to the desktop still gives a starter with a silly name I cannot 

I have no contacts, which is expected. How do I proceed now? In Akonadi, I can 
create resources for personal contacts and for an address book. No idea what 
the differences are, and if it matters. The Handbook does not find 
documentation for it, and the online docs are for 4.4. Ah, but there is a link 
to Akonadi stuff (http://userbase.kde.org/Akonadi_and_AddressBook), and there 
it says that the address book resource (the one storing stuff in 
share/apps/kabc/std.vcf) is not recommended. Fine, I just imported my contacts 
which I had exported before.

The nice thing is that I optimized my desktop a little. I did not (yet?) have 
problems with KMail. Well, German spell checking did not happen, until I 
changed the language from 'German' to 'German (Germany)'. Whatever.

Now I need my KNotes. There's no import/export feature... I have a KNotes 
resource, pointing to .local/share/notes, and there are some sub-directories 
in it, and some have content, although it looks like old versions of my 
KNotes. They probably were migrated when I started the new Kontact 
for the first time.
So I just copied over the .kde4/share/apps/knotes folder. Notes are back, but 
Kontact instantly crashed when I switched to KMail. After this, it seems to 
work, though. But still the Akonadi Notes resource points to 
.local/share/notes, but I do not see that content.

I still have to do keyboard shortcuts, toolbars, and migrate my local mail 
folders. What might be the difference between the 'KMail-Maildir' and the 
'Maildir' resources? I chose to create a KMail-Maildir resource pointing to my 
local mail directory (which I got from my backup, since KMail somehow deleted 
those mails). KMail now shows the mail folders, but they are all empty. The 
'Backup' folder has sub-folders, but they are empty, too. Those are the mails 
I want to have. Same result when I create a 'Maildir' resource. Maybe Akonadi 
is still indexing stuff or something, but if so, some progress indicator would 
be fine.
No, there is no content in the folders. I removed the KMail-Maildir and 
Maildir resources, stopped Akonadi and KMail. tried again, but when I now 
create such a resource, it's named 'akonadi_maildir_resourcea<n>', while 
before it was the name of the mail directory. And it is completely empty, no 
subfolders at all. I deleted them again, and created a KMail-Maildir resource, 
and now it shows the folders correctly, but again without content.

Hmmm. Looking into this mail directory by hand, the 'Backup' directory is 
indeed empty. But there is a '.backup.directory' directory, and in there is 
the data. So I created a KMail-Maildir resource pointing directly to that 
directory. Crash! Restarted Kontact and KMail does not crash, but again, it 
shows the folder structure, but no mails.

I don't quite understand this, because I did these steps before, and at least 
I could see the mails. 

Ah, suddenly I get the notification that 'Nepomuk Indexing Agents Have Been 
Disabled' again. The problem is that Nepomuk is not running. This time I can 
read the notification, and make it appear again by clicking on the 'i' left to 
the system tray.

Enough for now, there are other things to do. So, I spent quite some time, but 
KDE stuff still crashes a lot, and some things don't work. So maybe Duncan's 
second theory is right, about me being one serious unlucky guy. Still, I'm no 
too disappointed, I learned some stuff, and at least much cruft is gone. And 
login is much faster now. So there _are_ some benefits. 

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list