A week of KDE4 usage

Alex Schuster wonko at wonkology.org
Wed Jul 6 11:56:26 BST 2011

Kevin Krammer writes:

> On Monday, 2011-07-04, Alex Schuster wrote:
> > Kevin Krammer writes:
> > > On Saturday, 2011-07-02, Alex Schuster wrote:

> > > Hmm, using KDE localized for German myself I can't really agree
> > > with this. Do you have an example of something not being translated
> > > properly?
> > 
> > Sorry, no. Since 4.6.3, nearly all my KDE applications suddenly are in
> > English. An exception is systemsettings, although the applications in
> > it are English again. The K menu also has German entries, and the KDE
> > Help Center has most stuff in German. Must be some bug because
> > kde-l10n is installed, and German is set as application language in
> > the help menu. I don't care much, let's wait and see if 4.7 will
> > correct this.
> > 
> > Before 4.6.3, most things were German, but sometimes dialogs were not.
> Since Debian packages seem to work just fine it could be either a
> packaging or configuration issue. Does this happen for all user accounts?
> Also new ones?

Yes, I just created a new user and verified this. BTW, this user is unable 
to log out - when I try to, the background gets greyed out, but then nothing 
happens. The desktop is still usable, except for the logout feature. 

Now I looked at the files installed by the kde-base/kde-l10n package. I 
expected *.qm files, but instead the translation is done by *.mo files in 
/usr/share/locale/de/LC_MESSAGES. Ah! So I checked my $LC_MESSAGES variable, 
and it was set to 'C'. My fault, obviously. I corrected this, and 
everything's in German now! Well, nearly everything, but I'm impressed. Most 
stuff in Systemsettings is still in English, but when I check applications 
like Konsole, Konqueror, Dolphin, Gwenview, all is translated.

I just stumbled upon http://l10n.kde.org/stats/gui/stable-kde4/team/ on 
Planet KDE. Now that's a LOT of languages.

BTW, after logging out and in again to apply the LC_MESSAGES changes, I ran 
into bug #266129 (knode displays **HUGE** icons), but I could solve this 
easily again. Strange, I have no idea what could have triggered this, I just 
had logged in not long before and did not change any settings.

> > I have never used WLAN with Linux before, and I hoped that it would
> > automagically work.
> It usually does. My laptop has had its fair share of unencrypted, WEP, WPA
> and even one WPA-PSK networks, all quite simple through network manager.
> Occasionally even mobile broadband (though I prefer PPP tools there for
> fine tuning some options).
> > The interfaces came up, but when I tried to connect, I
> > was asked for the WEP password. Some notice that my WLAN drivers were
> > not capable of WPA would have been nice, I did not know what was the
> > problem. Or a list of the interfaces capabilities.
> > I still do not understand why a PCMCIA card did not work, that worked
> > out of the box with an earlier Ubuntu Version. After I flashed the
> > internal card, WPA suddenly worked.
> Ah, I have a nicely supported integrated Intel Wireless 3945. Might be
> different with plug&play hardware.

After flashing the device, WPA was not problem any more. But I had a hard 
time to find out what to do. I found several howtos for Ubuntu or openSUSE 
(which I also gave a short try before), but none really explained what 
needed to be done. People just gave a summary what _they_ had to do in their 
specific case, but not what the basic concepts are. Maybe I should have 
tried the Gentoo docs instead, they are of good quality often and focus on 
the technical details. Or find some other basic documentation. But then I 
just wanted to do a quick install, and I wouldn't have bothered to flash the 
internal card if the PCMCIA card were working. Which it did, with an older 
Ubuntu. I even thought about just installing that again, but then I did not 
like to do yet another install again.

> > But the interface often does not come up after resuming from suspend
> > to RAM or disk. Sometimes the connection also drops during normal
> > usage. I get a notification that the interface is down, but
> > NetworkManager still shows it as up. I have to manually disconnect
> > and then connect again.
> Ah, strange.
> I have seen drops but then the interface was really gone on all levels.
> Reconnect after resume (from standby) works every single day (my laptop
> suspends to RAM every evening and is resumed every morning).

For me it works only 50%, and I tried a lot of times.

> > I also did not find a
> > quick way to turn it off altogether, I would prefer the interface to
> > be up all the time, even if no one is logged in.
> Permanent connections can usually be configured by whatever system the
> distribution uses for networking.
> Definitely works with Debian's networking/interfaces, with either
> NetworkManager stopped or not installed.

Yeah, I looked into this before I had flashed the card, trying Yast on 
openSUSE, but at that point the device was not yet capable of WPA. The same 
goes for that PCMCIA card, which is strange.
And later I did not try again, as I was running short on time, I don't live 
near my mom so I had to make the thing run while I was visiting her.

> NetworkManager even has support for getting some configurated networks
> that ways, but I haven't tried that option myself yet. Will likely also
> depend on some distribution specific plugin and might not be supported on
> Gentoo.

I was using it on Linux Mint, a derivative of Ubuntu. While I love Gentoo 
very much, I don't use it for systems I do not often have access to like my 
mom's notebook. And that I don't want to update often.

In the end, it sort of works, and she is happy. All this internet stuff is 
new to her. But she's retired now and has some time to spend. Google Street 
View was quite a shock for her though :)

Wow, we're really offtopic now :)

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list