Some more weeks of KDE4 usage (was: Re: A week of KDE4 usage)

Alex Schuster wonko at
Sat Jul 2 15:38:14 BST 2011

On 2011-05-12, Rafa Grimán wrote:

> On Thursday 12 May 2011 00:27 Alex Schuster wrote
>> Rafa Griman wrote:

>>> So the thing is: have you tried another distro? Honestly, change
>>> distros and you'll see that KDE SC isn't as bad as you think.
>> Nooo way, this won't happen :) Sorry, but I just love Gentoo Linux. I'd
>> rather give up KDE4 than using another distro for my personal purposes.
> So, Gentoo. Also a Gentoo user :) Could it be the compile options you're 
> using? I know some people use very agressive compiler options and then the 
> system is quite unstable ...

I'm optimizing for my CPU, but don't use aggressive compile options,
it's only "-march=k8-sse3 -mfpmath=sse -O2 -pipe". Should be safe.

And I wouldn't say my system itself is unstable, I do not get weird
compile errors that aren't reproducible. Most of the time I can work
fine, when I do my usual stuff. Many of the bugs are already reported on or can be reproduced by others.

The problems mostly happen when I try new things. Add some activities, play
around, delete them, and on the next reboot you have them again, or even
more. I'm not the only one with this bug.
Some versions ago, dragging a plasmoid from the panel to the desktop
would make plasma crash, reproducible.
About a third of the plasmoids I download and try do not work or make
plasma crash.

Since my initial posting, I noted most of the problems as they happened. Not 
all are KDE4 problems, but most of them. Here we go. Oh my! When I start 
marking the stuff I wrote in KNotes and scroll down, suddenly the whole 
marked text becomes bold, so I just found another bug while starting to 
write about the other bugs.

Problems with my dynamic IP that is managed by Main problem 
was on their side, but I had weird problems with their user interface which 
was Konqueror's fault. Probably the same bug that sends double requests, 
this also happens when filing bugs at, you get a conflict 
message then.

Konqueror does not show the login field for any more. Did not 
know about the above problem yet so I use Konqueror again, not Firefox.

Some problem with my 'bgo' web shortcut in Konqueror for 
Got a 'updating config' message in an endless loop, don't remember the 

Akregator dies on a web site.

kwin is using 891M!

Konqueror asks for confirmation of certificates for my online banking. But 
no other browser does this.

Akregator: Crashes when clicking 2 URLs quickly.

Dolphin -> Settings -> Configure Dolphin -> Services -> Download New 
Services: desktop #5 is no longer accessible

Suddenly the mouse no longer reacts correctly. I restarted X, same effect. 
Reboot, all is fine again.

Some similar problem with the mouse, I don't remember what that was. 
restarted KDE, now some of my desktops are swapped ore gone. But I know what 
files to get from the backup to make it work again.

Konqueror crashes when accessing Webmail (I don't do this normally)

My USB-Stick is not being recognized, mounting by hand.

Wallet does not open

KSsnapshot -> Send To does not work, file not found error. have to save 
first. Known bug.

My test user is unable to log out. background gets greyed out, but desktop 
is still usable. Well, except for the logout feature.

kded4 process hogs CPU time. Sometimes then knotify4 does the same.

I installed the steampunk splash screen, but it is does not show up. 
Eventually worked after the next login or something.

kdesu asked for the password, I canceled. After this, I ALWAYS get the error 
'unable to authenticate/execute the action: code 4). I have to log out and 
in again to make kdesu work. Right after this PolicyKit1-KDE crashed.

Started Emilia-Pinball in fullscreen, it hangs, had to kill X.

Installed the new Simple CPU Usage plasmoid, played with the options, plasma 

Konqueror does not scroll a web page

TV-Browser becomes invisible

Ran into bug #168865 from 2008, Akregator & Ctrl-C does not work.

Spell check: Skip uppercase does not work; Words with the German umlaut 'ß' 
are shown as wrong, same goes for words with an apostrophe.

kwin using 600M, Konqueror window has no border, Menus & Windows are gray or 
black -> restart KDE

KNode: compositing window -> Settings -> Configure Kontact opens KNode 
settings, not those for Kontact

Kontact crashed silently

kwin uses 1.3G, again weird effects happen. After relogin: Plasmoids are not 
movable, I have to lock and unlock them to do this. One plasmoid is in an 
unusual place.

/var file system is full because of 2.3G in /var/tmp/kdecache-
wonkoHYUjvC/http/. I logged out, moved this to my home directory and created 
a symlink. Some days later the same happened, because now the directory is 
called /var/tmp/kdecache-wonkoHYUjvC. In total I had a full /var partition 
for four times, which made my web server and other services crash. Does this 
mean I need to have at least 5G of free space in /var when I have two users 
using my desktop PC?

Tried to open a remote remote mp3 with Amarok. It didn't work, but I did not 
note what exactly went wrong.

Dolphin crashes. Which means that _all_ Dolphin instances crash. And it's 
not so easy to recreate them because I have lots of them, with Tabs and as 
grouped windows.

KNotify shows Jobs without a name until I stop them. This happens 

kwin is at 779M, the system is quite slow.

KDEPIM update leads to big Akonadi problems, KMail is unusable. Posted about 
this in an extra thread weeks later when I solved this.

Akregator shows many old news again, I have them two times now.

K menu has no programs, krunner did not find applications unless I gave 
their full name. Got the hint to create a missing symlink to kde-4- as /etc/xdg/menus/, this did help for a 
test user, not for my own account. Tried kbuildsycoca4 which had helped in 
the past, no success. Some days/logins later it suddenly worked.

Dolphin & FTP: Got a 'cannot read error', don't remember details.

Copied many files with Dolphin. The notification plasmoid kept changing its 
size for about 30 seconds, and the time estimation was as bad or even worse 
then in Windows XP, constantly changing from few minutes to hours.

Dolphin always had a problem with drag&drop, after dropping a file, the 
source panel acts as if the mouse button still was pressed, marking all 
files as I move the mouse. This has become much worse in KDE 4.6.4 and is 
really really annoying. Another problem is the scrolling, I drag a file onto 
a folder in a dolphin window, but just as I drop it the file list starts 
scrolling because the destination folder is near the top or bottom, and the 
file gets misplaced. Sorry guys, but the old Windows XP explorer does these 
things much better.

knotify: Shows no running jobs during copy

Dolphin title: size changing without mouse cursor. Sorry, I have no idea 
what this was, but I wrote it to my KDE4 bug log.

Noticed that dragging an image from Dolphin into a running Gwenview does not 
work. WHY?

Middle click on Comic plasmoid-> plasma crash

Konqueror: 'Connection to Server Refused', other browsers work fine.

Plasmoids are without menu, it comes back when I lock and unlock them again

Akonadi settings: 'The Akonadi server is running.', but it is not.

Kontact crashes when opening the settings dialog

KMail -> save draft -> crash (drafts folder did not exist)

DrKonqui: unable to log in (probably a remote problem)

KMail: 'There were problems trying to queue the message for sending: Message 
has invalid sent-mail folder.' Okay, but why, it was a valid folder before?

Send mail notifications:
  E-mail successfully sent
  Virtyou: Connection to server lost.
  Virtyou: Connection to server lost.

More KMail trouble, but it finally works

Nepomuk: Why does it take several minutes to calculate the number indexed 
files? When I tried that later, the calculation never stopped.

KMail sometimes asks for the password when sending mails, when I am not 
quick enough for allowing access to the wallet.

A mail was not sent, found it in the trash?!

KMail says there are unread mails, but it shows none.

Clicked a mailto: link in Konqueror, got a message that Kontact is already 

KMail did not check for mails, turned out the wallet was not being opened, 
could not even open it manually. When I logged out, I finally got a warning 
window about not being able to open the wallet. But I could read it as 
KMyMoney's crash dialog appeared above, KWin was no longer running, and when 
I quit the dialog I was being logged out. BTW, KMyMoney _always_ gives the 
crash dialog when logging out, so I normally quit it before logging out.

Right now:
kded4 hogs resources as it does frequently, along with knotify4. So I kill 
those processes.

KNotes: When marking text and scrolling down, the marked text becomes bold 
when bold text is being marked.

KNotes also changes the layout depending on whether the mouse is in or out 
of the window. I understand why, when the mouse is in, there are things 
being drawn like scrollbars and buttons. But it sucks that it shows stuff 
one page below that stuff that is shown when the mouse is in. I am currently 
copying my entries into this mail, and when I move the mouse into KNotes to 
mark an entry, the entry is gone and I have to scroll down a page.

Akregator keeps asking for the password of my Wiki every few minutes. This 
happens often, but not always.

And Amarok's progress bar is not usable. The position is shown so far as the 
bar is darker to the left, but there is no handle to drag. Skipping forward 
or backwards via hotkey also does not work. After playing another track, it 
is working again even with the track that just had the problem.

That's it, for now. There were some more things I did not note, like getting 
multiple password confirmation dialogs for KMail or Akregator every few 
minutes, so I have to close about 30 notice boxes when I get back to my PC 
in the morning.

Waiting for KDE 4.7,

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list