Sound HDA Intel (Analog Devices AD1981) doesn't work with phonon anymore?

Duncan 1i5t5.duncan at
Fri Feb 11 02:17:52 GMT 2011

Torinthiel posted on Thu, 10 Feb 2011 23:33:20 +0100 as excerpted:

> On 01/29/11 10:12, Johannes Schaub (litb) wrote:
>> Starting some months ago, KDE's phonon doesn't work with my soundcard
>> anymore. For example, instead of showing the usual 9 mixer channels I'm
>> shown with alsamixer (Master, PCM, CD, Mic, Mic Boost, etc), kmix shows
>> only one weird "Internal Audio Analog Stereo" channel, where I have no
>> clue what this means.
>> I tried to look into the phonon settings (systemsettings). But when I
>> open it, it sometimes shows a message box saying "Some Soundcards were
>> removed from your system. KDE thinks it's save to remove these from
>> consideration for future.". I have no clue what this means.
>> My soundcard works fine with all alsa apps, and I have no problems with
>> it. But phonon insists it's not there. What's wrong?
> Could someone shed some light on this? I seem to have the same issue. At
> first Amarok was working, now, after I've regenerated modules.conf
> (probably) it won't work anymore. Everything else (browser, MPlayer,
> skype, some games) work properly and even mixer works and programs obey
> it's settings. Yet at every start of KDE I get the same warning saying
> that "Some soundcards where remover from your system".
> This happened on update from 4.3.5 to 4.4.5, although most of my system
> was updated at that time, so it might as well be related to some other
> update

For lack of anyone authoritative jumping in on this... I'll give it a try, 
as I've had my own (apparently less serious) go-rounds with phonon wanting 
to remove stuff, too.  But this is simply power-user educated guessing, so 
if someone who actually knows, replies, take their statements over mine.

Observation:  Phonon appears (or at least with earlier versions, appeared, 
at least later 4.5 and now 4.6 seem to have settled down somewhat, for me) 
to be overly sensitive to certain errors it apparently gets occasionally 
when trying to tickle the ALSA drivers.  It thus decides the devices 
aren't there at all and wants to remove its memory of them, even when 
they're actively up and working, with other apps or even, apparently, kde, 
using another phonon device profile, at the time.

What seems to have triggered the situation here is that I apparently made 
a mistake, telling it to "show advanced devices" and choosing one of 
those.  The problem, it would seem, is that it's so sensitive to changes 
that it counted the same device three different times, and I chose the 
wrong one.

For months after, nearly every time I started kde, and IIRC occasionally 
in the middle of a session, it'd popup its warning saying it couldn't 
detect that device, even tho everything... including kde sounds, was 
working fine (it apparently fell back to something it /did/ detect, from 
you guys' posts I was lucky as it sometimes doesn't actually detect a 
working instance).

I always told it to go ahead and forget about that device, as it was 
obvious that whatever device it was currently detecting and working with, 
was working.  But still, the next time, I'd get the same message.  I never 
did figure out whether it was simply not removing what it offered to 
remove, thus constantly offering to remove it over and over again, or 
whether it constantly decided the old detection wasn't there and detected 
the same hardware as if it were new!  But it always seemed to work, 
despite always wanting to remove old stuff it said it couldn't detect any 

Happily, somewhere I believe late in the 4.5 cycle (4.5.3-ish if I had to 
guess, it might have been a bit earlier, you don't always notice the 
absense of such annoyances immediately), at least for /my/ hardware, 
phonon apparently got whatever bugs worked out, and either finally 
successfully removed what it had been complaining about all this time, or 
quit redetecting the same hardware as new and wanting to remove its old 
instance.  In any case, I quit getting the popups and things work pretty 
much as one would expect, now.  4.6 has continued that, now without hal, 
using udev/udisks/etc instead.  Perhaps they moved the sound detection 
over in 4.5 and that's why it started to work, here, even if they didn't 
fully kill the hal dependence for other things until 4.6?

Oh, I changed something else phonon related too, very late in the 4.5 
cycle (4.5.4 I believe, I didn't do the 4.5.5 upgrade).  I switched, 
somewhat experimentally, from the phonon-xine backend to phonon-vlc.  I 
didn't have VLC on my system before but was trying it for something else, 
and decided to try its phonon backend as well, as I'd read some kde-dev 
blogs earlier, saying the xine backend, being first, tended to be the 
default, but they liked the vlc backend better for programming with, and 
it would likely be better going forward.  It's /possible/ that had 
something to do with it, as it /did/ change the phonon device options I 
had to work with, but I /think/ the detection-warning thing had settled 
down before that.

The other possible backend, from the blogs, is the gstreamer backend.  But 
I don't have gstreamer installed here at all, having kept it off my 
(gentoo, thus more choices than most distributions give) system for years, 
after having a bad experience with it, tho that was definitely at least 
one gstreamer major-version ago.

So, two conclusions here:

1) Try switching phonon backends.  phonon-xine was the original and may 
still be the default, but the devs call it legacy, so switching to 
something else is probably wise.  phonon-vlc is supposed to be the 
promising new one, altho at the time of the blog (4.4 era, IIRC, so about 
a year ago), it was still somewhat experimental.  But it /does/ seem to be 
working well for me.  phonon-gstreamer is the third choice, which I've not 
tried as I don't have gstreamer installed, but from the blog, it'd fall 
between the other two.  Also, the gstreamer backend would be the most 
likely default for gnome-default systems, since AFAIK it's a gnome-related 
technology (another reason I'm cool to running gstreamer here, as I'm not 
a gnome fan and don't have it on my system either, only gtk+).  So try the 
phonon-vlc backend if it's available for you.

2) This rule applies to kde4 in general.  Kde4 is changing very fast, and 
despite official kde assertions to the contrary, many people including 
myself believe 4.5 SHOULD have been 4.0 -- previous versions simply WERE 
NOT READY FOR NORMAL USE, again, DESPITE official KDE assertions to the 
contrary.  If you're using a version previous to say 4.5.3 (earlier 4.5 
versions had certain bugs, primarily graphics related, fixed by that 
point), you're using a version a LOT of people, even kde fans, consider 
not yet fit for normal use.  I *VERY* *STRONGLY* recommend upgrading, as 
your kde experience should be far better with the later 4.5s than anything 
previous.  (Do note, however, that the kdepim module including kmail is a 
bit of an exception.  They're working on a major upgrade for it, and have 
continued releasing 4.4.x series updates for it that are compatible with 
the rest of kde versions 4.5 and 4.6.  The kdepim 4.5 and to-date 4.6 
versions are officially beta, with 4.4.10 being the latest in the 4.4 
series, the one you'd be expected to use with kde 4.6 in general, unless 
you /want/ to try the beta kdepim.  kdepim includes kmail, knode, 
akregator, kontact, etc.  And with kdepim-4.4.7+, I'd recommend a switch 
from the former akonadi mysql backend to the newer and more stable akonadi 
sqlite backend, as well.)

Hopefully those two suggestions/recommendations will help smooth your kde 
experience, as they have for me. =:^)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list