I just noticed: no more crashes! Thanks, KDE team!

Duncan 1i5t5.duncan at cox.net
Thu Aug 25 09:55:30 BST 2011

Alex Schuster posted on Thu, 25 Aug 2011 00:27:10 +0200 as excerpted:

> Hi there!
> I've been sort of busy for a while, and then a little ill, so not much
> acitivity here and with KDE. But here comes an update.

About two days ago I was thinking about one of the bugs we had discussed 
and wondering what happened to you.  But yeah, "real life" sometimes 
interposes, for sure.

> Duncan wrote:
>> Dotan Cohen posted on Sat, 06 Aug 2011 21:04:31 +0300 as excerpted:
>> > Dolphin has the separate process option too, it's just in Konqueror.
>> > From what I understand enabling this option in Konqueror enables it
>> > for Dolphin as well, because the Konqueror file manager in KDE 4 is
>> > just an embedded Dolphin part.

>> Looks like between you and me, we just solved Alex's problem, as soon
>> as he sets that option! =:^)
> Works fine, thanks Dotan!


> I also switched from Dolphin to Konqueror.

> I had to remove the web search field in the toolbar, because that would
> make the address field too small. I wonder why the search field is
> active when Konqueror is in file management mode, this does not make
> sense to me. But it's no problem, I don't use this field much, and use
> the shortcuts (gg for Google etc.) instead.

I don't know why it's there in file management profiles unless that 
setting isn't per-profile, which could be the case, since killing the 
search bar is one of the first things I do, regardless of the browser.

But FWIW, pretty much all the browser folks I've seen blog about it say 
the search bar, like the go button on the address bar, is mainly there 
for the "computer challenged".  That's why the search-bar feature almost 
always defaults to on, regardless of the browser (as long as it has the 
feature), but again almost always, has an option to turn it off.  Those 
comfortable with computers are expected to prefer having the window real 
estate for other things, since the address bar can do search just as 
well.  Similarly with the go button, those comfortable with computers are 
most likely using the keyboard to input the address (or search) anyway, 
if they're using the address bar at all, and they'd consider it a bug if 
the enter key didn't do what the enter key does, so they don't need or 
tend to use the go button at all, and even if they do, tend to prefer 
that space be saved for something more useful... like a couple extra 
characters of text entry length so as to see more of long addresses, for 
instance.  So  in both cases the default is on but it is expected to be 
quickly turned off by those who actually know how to work a config 
dialog, since the purpose in both cases is for those scared of such 
things. =:^)

> I also don't like how Dolphin/Konqueror start scrolling
> when I drag files to a folder that is near the top/bottom. There is a
> little lag, so when I drop the files, they end up in the wrong folder as
> the thing just started to scroll. Really, I sometimes wish it would just
> work like Windows XP's explorer, where at least I do not have such
> problems.

I've not used MSWormOS for so long (save for very occasionally on others' 
systems, since 98, as MS pushed me off with eXPrivacy) that I really 
don't have the foggiest how it operates any more.

But I too occasionally have DnD drop-scrolling issues.  Generally not bad 
ones, tho, since I've learned to pause over the target slightly, 
confirming that it's going to do what I want, before I drop.  Thus, I've 
generally not dropped yet when it scrolls, and I can grumble just a bit 
and trigger a reverse scroll so I can drop the stuff where intended.

But 90+ percent of my moves and copies are either in mc or at the command 
line anyway, and about half the rest are via browse-dialog instead of 
DnD,so it's not something I run into much since I simply don't DnD much.

> About the crashes with Gwenview showing multimedia files: My bug report
> [#279624] was confirmed by someone else. I found out that this only
> happens with ffmpeg 0.7.3 installed, so a downgrade solved this problem.
> I reported this upstream in [#410], and it looks like they found the
> problem. It will be solved in 0.7.4.

Looking at the bug, no wonder I didn't run into it.  I had strigi and 
nepomuk turned off, and now have USE=-semantic-desktop set and don't even 
have nepomuk at least, installed (strigi seems to be an unconditional 
depende of kdelibs, but whatever, at least it seems harmless without 

> List of weird stuff happening in the last weeks since I last wrote
> something here:
> One day, the bouncing mouse cursor that indicates a starting program did
> not go away. The problem was that I was doing important stuff involving
> VMware Player, and could not easily log out and in again for a while.
> This drove me crazy :)

I used to have problems like that occasionally, but haven't in quite 
awhile.  When I did, I made it a point to configure a custom busy cursor, 
that still had a pointer (the background-busy from a different cursor 
scheme, usually), so if it got stuck, I could still use the pointer.  
(I've not had the problem for long enough now, that I've changed the 
cursor theme a couple times and if it got stuck, I'd be in trouble, since 
I'm using the gentoo theme ATM, with the little UFO dude (who I believe 
is named Snert) as the busy cursor, and it doesn't have a pointer.  But 
if it starts to happen again, I know what to do...)

> On two occasions, the Windows and Ctrl keys no longer worked. Had to log
> out and in again.

That's weird.  I've not see anything like that recently, at least on my 
machine (something similar happened at work today, tho, to the POS 
system, rebooting fixed...), but if it was going to be a bother to 
logout, I'd probably first try unplugging/replugging the USB keyboard, 
then if that didn't work, run something like xev to check if they were 
still being detected at all, then fiddle with kde's keyboard settings if 
xev was detecting them, and finally try xmodmap or the like, if I still 
wasn't ready to try logging out yet.

> Konqueror once was not able to log into my online banking site, I got an
> error that I had to give account number and password, which Konqueror
> clearly showed, but they were not sent. Again, after the next login the
> problem was gone.

No idea, but FWIW, both konqueror and firefox are setup to work with my 
bank, here, and of course firefox is now my default browser, after the kde 
4.6.2 konqueror double-submission bug proved to be the last straw, for 
me.  But you know that part...

> For some days now, when I start Konqueror and enter any URL, LibreOffice
> starts. I have NO IDEA why. Sometimes this even happens when I am using
> Akregator and show a site in a new tab. Weird.

Let's see if I've guessed the problem right on this one.  Check the file 
associations (kde settings, common appearance and behavior, file 
associations) for text/html and/or application/xml.  It's likely one of 
them has LibreOffice set to the highest priority association, so it's 
what's loaded.  Depending on how it's parsed, especially from within 
konqueror it might recongize the content as something that it can handle 
and load it normally, while from anything else, the association is 
checked, leading to libreoffice opening the file.  But it can look random 
to to the uninformed or if you're not paying attention.

You may also need to run kbuildsycoca4 manually, if just Kde's SYstem 
COnfig CAche (k-sy-co-ca) somehow got screwed up, but the text-file config 
is proper.

> Suddenly, *.wav files are associated with Dolphin? And opening a .was
> file with Amarok did not work. probably unrelated, but at this moment I
> started getting high load, up to 52, iotop showed the akonadiserver
> process doing stuff.

.was or .wav?  I'm not familiar with .was files, but in context, perhaps 
you meant .wav in both cases?

No more akonadi on my system, here! =:^)  Even assuming akonadi's working 
right, unloading it was if I just got a 500 MHz or a couple extra cores 
upgrade, for free! =:^)

FWIW, claws-mail is growing on me quickly, too.  I'm /extremely/ pleased 
with how that decision turned out, here. =:^)

But I know you like the integration of kontact...

> Downloading subtitles from opensubtitles.org with Konqueror resulted in
> many, many crashes.

Subtitles is something I seldom have to worry about, as I rarely do 
movies and even more rarely do non-English movies (except occasional 
youtube), so not a clue on that.

> And while I usually opened the .zip files in Ark and
> dragged the files I needed to the destination, Ark now does not show any
> files, so I have to save the .zip file and unpack manually.

Hmm... sounds like it might have lost its zip library compatibility.  
Have you done an emerge --update --newuse --deep @world recently, 
followed by a revdep-rebuild?  And/or try rebuilding libarchive and then 
ark, since I think ark handles zip files using libarchive.

> akonadi_maildispatcher_agent once crashed when sending a mail.

No more akonadi here, YAY! =:^)

> Sometimes, clicking at desktop #3 on the pager plasmoid in the panel
> does nothing. Only happens with this desktop, not the 5 others. My
> shortcut still works, which I prefer anyway because it is faster - the
> reaction is instantaneous, while when using the plasmoid it sometimes
> takes over a second until I get a response. Huh?

FWIW, I don't use the pager plasmoid.  I have the scrollwheel action on 
the desktop set to change desktops and that's what I use most, and 
there's win-g/desktop-grid or win-c/cube or win-Fn/desktop-hotkeys or 
simply alt-tabbing to whatever app on whatever desktop, as backups or if 
I feel like it, instead.

Plasma is unfortunately single-threaded (there was a thread on that 
recently, I don't agree with the whole single-threaded idea, ESPECIALLY 
since plasma's intended to be extensible thru plasmoids of who knows 
/what/ sort of quality and stability), so if some other plasmoid is 
keeping it busy, or on slow systems with lots of real-time meters, etc, 
perhaps just due to that, anything plasmoid-based is going to end up 
waiting in line for plasma to deal with, with its single thread.

I'd guess that's what's going on.  Oh, well...

> Discovered a problem with KMail2 not showing header titles (like From:,
> To:,
> X-Bugzilla-URL:). Filed bug [#280670].

No more kmail2 to worry about, YAY! =:^)  (FWIW, claws-mail lets you 
configure which headers to show, or not show, your choice, specifically.  
So all my bugzilla mails now come thru with most of the X-bugzilla-* 
headers shown, for instance, since that's how I configured it. =:^)

> Another Kmail2 annoyance is that the subject and sender is lost when
> KMail is quit with open composing windows. After restart, the windows
> re-appear, but I have to find and enter the subject manually. Happened
> countless times for me, also with this mail. Known bug [#280642], fixed
> in 4.7.1.

No more kmail2, YAY! =:^)

> One day, KMail did not show any new mails in the morning. Had to restart
> both Akonadi and KMail to make this work again. In the meantime, weird
> things happened, like KMail showing only very few mails in some folders.

No more kmail2 here, YAY! =:^)

> Krunner died. But I could simply restart it in a terminal. Nothing I
> would even mention, if the subject to this mail were different.

FWIW, krunner was MUCH more stable for me after I followed the suggestion 
at the bottom of this page, disabling the krunner nepomuk search plugin 
and the contact plugin.  That was while I was still running akonadi and 
thus had to have USE=semantic-desktop.  Of course now that I don't, I 
don't even have those options to disable. =:^)


Meanwhile, I also setup a hotkey to run a "krunner-reset" script, so I 
can reset krunner from a hotkey if I need to.  Here's the script, all 
four lines of it including the shebang!:

killall krunner
sleep 1

I actually set that up late in 4.5 or early in 4.6, IIRC, when I was 
having problems with krunner either dying or simply failing to respond to 
its trigger hotkey, until I reset it.

>> BTW, Alex, you go by Alex in the from, but sign your posts Wonko. 
>> Which do you prefer, or does it matter?  Wonko's a more unique ID,
>> certainly by itself, but Alex is what shows up in the attribution line
>> when I reply to you and in the author column of my posts lists, since
>> that's what you use in your From: header.  Or maybe you prefer a more
>> formal "Mr. Schuster", or would it be "Dr." or some such?
> I prefer Wonko. The name is taken from the fourth book of Douglas
> Adams' five-part trilogy 'The Hitchhiker's Guide To The Galaxy'
> it's the guy (Wonko the Sane) who built the asylum.
> And damn right he was.


>> OTOH, to my Hispanic friends especially, Duncan mutates into Dunky,
>> which even more quickly mutates into Donkey... and from there to Burro!
>>  Which in Spanish can also mean dunce... but can also mean... well,
>> let's keep it family fare, but for some reason, the women seem to use
>> the term more than the guys, who tend to stick to Duncan.  Not that I
>> blame 'em!  (If you want to know the meaning of a word, wictionary is
>> your friend!)
> Well, then check this out:
> http://www.urbandictionary.com/define.php?term=Duncan

I saw the urbandictionary link and was almost afraid to click it, but I'm 
glad I did.  The descriptions seem surprisingly accurate (well, except 
for the great body bit, I'm a middle-aged geek, with the physique one 
might expect from too much sitting in front of the computer and too 
little physical exercise).

Thanks, Wonko! =:^)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list