I just noticed: no more crashes! Thanks, KDE team!

Alex Schuster wonko at wonkology.org
Sat Aug 27 00:45:11 BST 2011

Duncan writes:

> Alex Schuster posted on Thu, 25 Aug 2011 00:27:10 +0200 as excerpted:

> > Duncan wrote:
> >> Dotan Cohen posted on Sat, 06 Aug 2011 21:04:31 +0300 as excerpted:

> > I also switched from Dolphin to Konqueror.
> > 
> > I had to remove the web search field in the toolbar, because that
> > would make the address field too small. I wonder why the search field
> > is active when Konqueror is in file management mode, this does not make
> > sense to me. But it's no problem, I don't use this field much, and use
> > the shortcuts (gg for Google etc.) instead.
> I don't know why it's there in file management profiles unless that
> setting isn't per-profile, which could be the case, since killing the
> search bar is one of the first things I do, regardless of the browser.

The field wasted only a little space, and I didn't have to remember the 
shortcuts for the different search sites, but I don't miss it at all now.

> > I also don't like how Dolphin/Konqueror start scrolling
> > when I drag files to a folder that is near the top/bottom. There is a
> > little lag, so when I drop the files, they end up in the wrong folder
> > as the thing just started to scroll. Really, I sometimes wish it
> > would just work like Windows XP's explorer, where at least I do not
> > have such problems.
> I've not used MSWormOS for so long (save for very occasionally on others'
> systems, since 98, as MS pushed me off with eXPrivacy) that I really
> don't have the foggiest how it operates any more.
> But I too occasionally have DnD drop-scrolling issues.  Generally not bad
> ones, tho, since I've learned to pause over the target slightly,
> confirming that it's going to do what I want, before I drop.  Thus, I've
> generally not dropped yet when it scrolls, and I can grumble just a bit
> and trigger a reverse scroll so I can drop the stuff where intended.

I also drag a lot of mails into KMail folders, and this feels much, much 
better. The scrolling only happens when I drag to the very top or bottom of 
the folder list, and does not already start when I am near. And it starts 
instantaneously, not after a pause, when I just dropped the file.

> But 90+ percent of my moves and copies are either in mc or at the command
> line anyway, and about half the rest are via browse-dialog instead of
> DnD,so it's not something I run into much since I simply don't DnD much.

I use it mainly for sorting video clips I downloaded.

> > About the crashes with Gwenview showing multimedia files: My bug
> > report
> > [#279624] was confirmed by someone else. I found out that this only
> > happens with ffmpeg 0.7.3 installed, so a downgrade solved this
> > problem. I reported this upstream in [#410], and it looks like they
> > found the problem. It will be solved in 0.7.4.
> Looking at the bug, no wonder I didn't run into it.  I had strigi and
> nepomuk turned off, and now have USE=-semantic-desktop set and don't even
> have nepomuk at least, installed (strigi seems to be an unconditional
> depende of kdelibs, but whatever, at least it seems harmless without
> nepomuk).

Do you have Dolphin/Konqueror configured to show short infos for the files 
the mouse is over? I would think that -semantic-desktop disables the 
indexing done by Strigi, but in this case it looks to me that Strigi is 
doing the analyzing of what type of file this is.

> > List of weird stuff happening in the last weeks since I last wrote
> > something here:
> > 
> > One day, the bouncing mouse cursor that indicates a starting program
> > did not go away. The problem was that I was doing important stuff
> > involving VMware Player, and could not easily log out and in again
> > for a while. This drove me crazy :)
> I used to have problems like that occasionally, but haven't in quite
> awhile.  When I did, I made it a point to configure a custom busy cursor,
> that still had a pointer (the background-busy from a different cursor
> scheme, usually), so if it got stuck, I could still use the pointer.

Using was no problem at all, it's only that the constant hopping annoyed me.

> > On two occasions, the Windows and Ctrl keys no longer worked. Had to
> > log out and in again.
> That's weird.  I've not see anything like that recently, at least on my
> machine (something similar happened at work today, tho, to the POS
> system, rebooting fixed...), but if it was going to be a bother to
> logout, I'd probably first try unplugging/replugging the USB keyboard,

I had this before, maybe three times per year. The keyboard is PS/2, I do 
not dare to unplug it. This seems to be safe, but in theory this could kill 
the PS/2 port. And once when I did this, the keyboard did not work at all, I 
had to reboot.

> then if that didn't work, run something like xev to check if they were
> still being detected at all, then fiddle with kde's keyboard settings if
> xev was detecting them, and finally try xmodmap or the like, if I still
> wasn't ready to try logging out yet.

Maybe next time :) I just logged out. I do this from time to time anyway, 
because of a memory leak in KWin, that needs a lot of memory after some days 
of being logged in.

> > For some days now, when I start Konqueror and enter any URL,
> > LibreOffice starts. I have NO IDEA why. Sometimes this even happens
> > when I am using Akregator and show a site in a new tab. Weird.
> Let's see if I've guessed the problem right on this one.  Check the file
> associations (kde settings, common appearance and behavior, file
> associations) for text/html and/or application/xml.  It's likely one of
> them has LibreOffice set to the highest priority association, so it's
> what's loaded.


> Depending on how it's parsed, especially from within
> konqueror it might recongize the content as something that it can handle
> and load it normally, while from anything else, the association is
> checked, leading to libreoffice opening the file.  But it can look random
> to to the uninformed or if you're not paying attention.

But the object is not being opened in LibreOffice. The page shows up in 
Konqueror just as it should, but I get an empty LibreOffice document. This 
happens when I open Konqueror and enter a URL of a site that was flash 
content. ps axf shows this:

 9938 ?        Sl     0:03  \_ kdeinit4: konqueror [kdeinit] --preload
10682 ?        S      0:00  |   \_ 
/usr/lib64/nspluginwrapper/i386/linux/npviewer.bin --plugin /usr/lib32/nsb
rowser/plugins/nppdf.so --connection 
10705 ?        S      0:00  |   |   \_ 
/opt/Adobe/Reader9/Reader/intellinux/bin/acroread --display :0 -progre
ssPipe 3 -exitPipe 4
10740 ?        Sl     0:00  |   \_ /usr/lib64/libreoffice/basis-
link/program/nsplugin 17 18 -
10742 ?        Sl     0:00  |       \_ 
/usr/lib64/libreoffice/program/oosplash.bin -nologo -nodefault -nolockcheck 
10752 ?        Sl     0:00  |           \_ 
/usr/lib64/libreoffice/program/soffice.bin -nologo -nodefault -nolockcheck -

> You may also need to run kbuildsycoca4 manually, if just Kde's SYstem
> COnfig CAche (k-sy-co-ca) somehow got screwed up, but the text-file config
> is proper.

No change.

> > Suddenly, *.wav files are associated with Dolphin? And opening a .was
> > file with Amarok did not work. probably unrelated, but at this moment
> > I started getting high load, up to 52, iotop showed the akonadiserver
> > process doing stuff.
> .was or .wav?  I'm not familiar with .was files, but in context, perhaps
> you meant .wav in both cases?

Sure, .wav. Now they are being opened in kmplayer. And Amarok plays them 
fine. Whatever. Just one more strange thing that happened once and but no 
longer happened on the next login.

> No more akonadi on my system, here! =:^)  Even assuming akonadi's working
> right, unloading it was if I just got a 500 MHz or a couple extra cores
> upgrade, for free! =:^)

It uses quite some CPU resources here, from time to time.

> FWIW, claws-mail is growing on me quickly, too.  I'm /extremely/ pleased
> with how that decision turned out, here. =:^)

Maybe I will try it then. When I have some spare time, which I don't. or 
when the next major problem arises.

> But I know you like the integration of kontact...

That's not very important. One thing i that I used KMail for so long now, I 
got used to it, and as always I hope the bugs will become fewer over time, 
and this akonadi stuff hopefully also will get a speedup.
And what I would like very much is to get my mails indexed by Nepomuk. I 
don't have Nepomuk activated at the moment, though. But I'll try again now 
and see how much resources this will need. Let's see if virtuoso_t is still 
running tomorrow morning. I did not yet activate Strigi, but I will try this 
again, too.

> > Downloading subtitles from opensubtitles.org with Konqueror resulted
> > in many, many crashes.
> Subtitles is something I seldom have to worry about, as I rarely do
> movies and even more rarely do non-English movies (except occasional
> youtube), so not a clue on that.

I like to watch stuff in English, with English subtitles. Without, 
understanding is hard for me. Works fine for Futurama, but most movies are a 
pain to watch without subtitles for me.
Despite the good reputation, I do not like synchronized movies at all. 
German synchro may be good technically, but the translations are often 
silly. Plus the usual errors, like when silicon is translated as silicone, 
or billion as trillion.

> > And while I usually opened the .zip files in Ark and
> > dragged the files I needed to the destination, Ark now does not show
> > any files, so I have to save the .zip file and unpack manually.
> Hmm... sounds like it might have lost its zip library compatibility.
> Have you done an emerge --update --newuse --deep @world recently,
> followed by a revdep-rebuild?  And/or try rebuilding libarchive and then
> ark, since I think ark handles zip files using libarchive.

Ark is working fine when I open files with it. It's only when I download 
them. Maybe Ark opens before they are actually downloaded or something. Oh, 
it's working now.
It also no longer opens my $HOME directory after I dragged a file somewhere, 
which it did for years. Things become better!

> > Discovered a problem with KMail2 not showing header titles (like
> > From:,
> > To:,
> > X-Bugzilla-URL:). Filed bug [#280670].
> No more kmail2 to worry about, YAY! =:^)  (FWIW, claws-mail lets you
> configure which headers to show, or not show, your choice, specifically.
> So all my bugzilla mails now come thru with most of the X-bugzilla-*
> headers shown, for instance, since that's how I configured it. =:^)


> > Another Kmail2 annoyance is that the subject and sender is lost when
> > KMail is quit with open composing windows. After restart, the windows
> > re-appear, but I have to find and enter the subject manually. Happened
> > countless times for me, also with this mail. Known bug [#280642],
> > fixed in 4.7.1.

And again, with this mail.

> No more kmail2, YAY! =:^)

BTW, the threading seems to be broken in KMail. Your response does not 
appear below mine, but the references in your header seem to be okay to me.
AH, seems this is https://bugs.kde.org/show_bug.cgi?id=279115 . At least I 
don't have to report this.

> > Krunner died. But I could simply restart it in a terminal. Nothing I
> > would even mention, if the subject to this mail were different.
> FWIW, krunner was MUCH more stable for me after I followed the suggestion
> at the bottom of this page, disabling the krunner nepomuk search plugin
> and the contact plugin.  That was while I was still running akonadi and
> thus had to have USE=semantic-desktop.  Of course now that I don't, I
> don't even have those options to disable. =:^)

This happened only once so far, so I don't care about this. Yet.

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list