Possible bug in kwin or ??

gene heskett gheskett at wdtv.com
Tue Apr 26 17:49:03 BST 2011

On Tuesday, April 26, 2011 12:38:11 PM Duncan did opine:

> gene heskett posted on Tue, 26 Apr 2011 06:37:04 -0400 as excerpted:
> > On Tuesday, April 26, 2011 06:05:58 AM Duncan did opine:
> >> For the GUI inclined, [konqueror as a fileman) was/is decent.
> > 
> > I did get it set for 2 pane operation once, but I'll be damned if I
> > was able to make it copy a file from the left pane to the right. 
> > Whats a file manager that can't do that worth?  Zip.
> The keyboard copying is setup to ask you where to put it, so that
> wouldn't have worked.  But drag-n-drop (after selecting via keyboard if
> desired) should have worked.  I think that's what they expect, altho
> working without a keyboard shortcut can definitely be frustrating to us
> traditionalists.  (Well, in a graphical client such as that, I don't
> necessarily have an issue with drag-n-drop, as long as I can ctrl/shft
> click for multi-select.  But when you want it and it's not there...
> OUCH!)

> >> > OTOH,
> >> > features are disappearing from mc at a rate that will have it back
> >> > to failing kindergarten questions in another 2 or 3 years.  Yes, I
> >> > miss the glory days when mc could literally do it all.
> >> 
> >> ??
> >> 
> >> I'm a /regular/ mc user, and while I've seen some changes, the only
> >> /feature/ I know that has disappeared, last I checked, and I expect
> >> that was by accident, was sparse-file copying.
> > 
> > Humm, I'll have to see about that.  With large drives I had not
> > noticed the diff.
> I noticed it immediately, because I was doing whole-partition copy-
> backups, to identically sized partitions, then running df to check that
> the space usage was comparable.  Normally under those circumstances,
> usage will be either identical, or a bit less, due to inode churn on
> the working version while the brand new mkfsed one will have ONLY the
> inodes and directory tables necessary for the data just copied to it,
> as there's been no deletions yet.
> So when it the copy was suddenly not just a bit, but rather noticeably
> larger, it set off all sorts of alarms in my head, until I figured out
> what happened.  Actually, while I had read about sparse files, that was
> my first real experience with what I knew to be sparse files as I'd
> simply not had reason to notice it before, and I was really quite
> surprised at how much of a difference it ended up making.  (Note that
> this was on reiserfs with tail-packing on, so normal files were exactly
> the size of the data and sparse files were obviously smaller, no
> block-slack to worry about at the end of files, or to mask the real
> size of sparse files.)

Having been seriously bit by reiserfs back in the fog of time, I haven't 
touched it in 8 or 9 years.
> > I did find one gotcha recently, if copying a whole directory,
> > the auto-appended / on the targets filename will copy the dir to a
> > subdir/subdir, so you have to hand edit the target string & get rid of
> > he last /.
> What version are you running?  I recall some issues with that sort of
> thing as the new guy tried to fill corner-case wish-list bugs and the
> like (I actually traced one down as I was preparing to file a bug, and
> checked to see if there was anything related), but he ended up
> reverting that wish- list feature because it interfered with the way mc
> had always worked in other areas.  However, there were several versions
> with variations on the same theme as he tried tweaking things this way
> and that to try and make it work, before he finally simply reverted.

While I, given that the target dir already exists, and you just want to get 
the stuff from an old install, not over writing whats already there, but 
getting a whole /usr/usr subdir instead, caught be out.
> That was the one I actually traced the development and fix of, but there
> have been several similar behavior bugs.  However, as far as I've seen,
> copying seems to work properly again now, with (and probably
> since since I've seen a couple updates recently).
That is that is currently playing with my head.

> Oh, one that DOES still bug me is the auto-fill for mkdir (F7).  The
> auto- completion behavior is flat imbecilic, as it takes whatever
> filename you're on and tries to use that as the mkdir suggestion,
> INCLUDING THE .. ENTRY IF YOU'RE ON IT!!  Yeah, like making a directory
> named .. is going to work really well!!  DUH!!  But more to the point,
> using what's under the pointer as auto-fill for the new directory name
> is stupid regardless, since were it to actually happen, being an
> operation in the same directory, it'd replace whatever's selected with
> a new dir by the same name!

> But given my experience with the other one, I expect if I go look up the
> bug, that's actually useful in some corner-case that was filed as a
> wishlist item.  It'll probably get fixed... eventually.  But it's sure
> frustrating in the mean time!
> >> Oh, and I've had some problems with hotkeys not working in konsole,
> >> but that's because konsole's keybindings have undergone some major
> >> changes recently.  I admit I don't like them as stuff that used to
> >> "just work" doesn't now, but I suspect that'll get worked out in the
> >> end, as mc is still detecting konsole and expecting the old
> >> keybindings, some of which have changed.  Once they get in sync once
> >> again, I expect it'll all work.
> > 
> > The keybindings are major to me.  It hasn't show me a gfx image in a
> > year, which was handier than a button on the outhouse door when
> > verifying that I was about to attach an image to an email, forcing me
> > to use gimp for that.
> That's probably an extension file change.  You can edit the extension
> file and put whatever you want to open image files in that entry.
> And yes, I know editing it works, as I've changed it to use gwenview for
> image display. =:^)

I'll have to look into that, but I'll be out of pocket for the next week.
> > I haven't tried recently, does its ftp client still
> > work from its own command line?  New brooms tend to nuke that which
> > they no not about.
> It has every time I've tried it, tho I don't use that feature as much as
> I imagine some do.  But I definitely do use it, and it has always
> worked when I do.

Good.  I sort of settled on gftp for that function though.
> > Krusader, the last time I looked, was "all hat & no cattle".
> I imagine some day I'll have to install it, if for no other reason than
> to be able to say I've tried it.  But that description sounds like
> something I might be able to use myself, in any case. Thanks for that
> at least! =:^)
> > Digikam is another that has been forced on me by a ptp camera.  Its
> > picture database ability, and its ability to find and reuse one you
> > finally convinced it to generate, sucks dead toads through soda
> > straws. Why not a std menu that simply lets you navigate to where you
> > want to store the pix? No way in hell can you find that.
> LOL!
> You might try the "kamera" application.  AFAIK, it's simpler.  I have a
> webcam on my netbook and tried installing kamera to use it.  But
> apparently, despite the name, webcams aren't considered actual cameras!
> The only ones handled, it seems, are cameras with actual onboard
> storage. I wanted a viewer and snapshot app but kamera obviously isn't
> going to cut it.

I use cheese for that. ;)
> I did find a couple apps for it, but a number of the others have broken
> builds with kernel 2.6.38+ because they depend on a video4linux-1 kernel
> header that's no longer there as v4l-1 has been deprecated for quite
> some time and was finally removed with 2.6.38.  It has been deprecated
> for years, why are they trying to still use the header?  But they are,
> and the build is broken as a result.  Gentoo should have patches for
> them (or perhaps will mask and remove them from the tree if upstream is
> dead) in a couple months, when they stabilize the 2.6.38 kernel, but
> meanwhile... the webcam was one thing I hadn't tried yet on the netbook
> until recently, and now several of the apps I'd ordinarily be able to
> build and try for it have broken builds! =:^(
> Anyway, kamera didn't work for me, but perhaps it'll work for you.  I
> know it supports ptp cameras as I found that out trying to figure out
> what to use for UVC (USB Video Class) webcams, only to eventually
> figure out the weren't supported, despite being a reasonably generic
> standard, apparently because as I said, it doesn't consider cameras
> without dedicated onboard storage actual cameras!

I don't even know if its in the pclos repo.  If I think to check, and its 
there, I'll install that too.  Thanks for the heads up.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
The average individual's position in any hierarchy is a lot like pulling
a dogsled -- there's no real change of scenery except for the lead dog.
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list