KDE 4.4 Desktop Icons/Application shortcuts error

Duncan 1i5t5.duncan at cox.net
Thu Feb 25 20:55:22 GMT 2010

Jozef Šiška posted on Thu, 25 Feb 2010 21:12:25 +0100 as excerpted:

> JayLinux wrote:
>> On openSUSE 11.2 with KDE 4.4:
>> On trying to run any application on the desktop, it gives an error
>> message, which shows the file as a <.desktop> file with a red
>> exclamation mark (?) and says that the file should be executable to run
>> (checking properties of the file, all are executable, as they are
>> applications/application shortcuts). This happens with all apps on
>> desktop: Firefox, OpenOffice.org Starter, etc. (Images [1], [2] - these
>> are for Firefox, but happens with any app/shortcut on the desktop). It
>> shows the same error message on trying to run the app/shortcut
>> subsequently also.
>> Image [3] is details of the properties for the desktop shortcut for
>> Firefox.
>> I tried chmod +x -R /home/user/Desktop, but the problem persists.
>> However, the apps can be run from the Kicker /Classic KDE Menu.
>> Jay
> Seems that kde automatically changes the permission to include execute
> on .desktop files here.. (I created a .desktop file on my deskop without
> execute set, launched it and it and execute was set after that...)
> might be that your home is on a partition mounted with noexec option?
> btw I don't really see why KDE wants execute set on .desktop files...
> the programs they refer to certainly.. ;), but the .desktop files
> themselves? they are just launchers/links

This is all based on a security vuln found in the original handling of 
*.desktop files a year or two ago (IIRC it was in the concept as adopted 
by the fdo .desktop file standard, so applied equally to kde and gnome, 
and anything else using that standard, at that point).  The solution was 
to treat them like executables -- refuse to run them unless they're set 

There's rather more to it than that -- IDR the details, but that's why and 
how executable permissions got involved in *.desktop files.  Based on 
that, I imagine you can google all sorts of detail, if desired.

The OP's problem must be some hiccup in the system, but I don't know 
enough detail about it to help, much, beyond this hint that should give 
someplace to start with google.  The only thing I can add is that certain 
dirs, likely including the desktop dir, are treated a bit differently 
automatically, which is probably how you're getting exec added 
automatically, and that I seem to remember some sort of bug when the 
desktop dir was moved elsewhere, but part of the system for some reason 
didn't know it, and thus didn't switch this automatic handling along with 
the move. 

That, and, speculating a bit, on systems with SELinux activated by 
default, traditional *ix file permissions are only part of the picture.  I 
don't run SELinux here, but I suppose it's possible that its permissions 
are interfering as well, not allowing the execute.

But I'd definitely start by googling desktop file execute permissions (try 
it on the Linux specific search site, google.com/linux), and see just what 
comes up.  Hopefully, that's enough of a point in what I believe is the 
correct direction, and a bit of research can take it from there.

If you find some good info and/or a useful solution, please do post, as 
this sounds like a problem that might come up again. =:^\

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list