KDE 4.4 Desktop Icons/Application shortcuts error

Jozef Šiška yoyo at gm.ksp.sk
Thu Feb 25 20:12:25 GMT 2010

JayLinux wrote:

> On openSUSE 11.2 with KDE 4.4:
> On trying to run any application on the desktop, it gives an error
> message, which shows the file as a <.desktop> file with a red
> exclamation mark (?) and says that the file should be executable to
> run (checking properties of the file, all are executable, as they are
> applications/application shortcuts). This happens with all apps on
> desktop: Firefox, OpenOffice.org Starter, etc. (Images [1], [2] -
> these are for Firefox, but happens with any app/shortcut on the
> desktop). It shows the same error message on trying to run the
> app/shortcut subsequently also.
> Image [3] is details of the properties for the desktop shortcut for
> Firefox.
> I tried chmod +x -R /home/user/Desktop, but the problem persists.
> However, the apps can be run from the Kicker /Classic KDE Menu.
> Jay
Seems that kde automatically changes the permission to include execute on 
.desktop files here.. (I created a .desktop file on my deskop without 
execute set, launched it and it and execute was set after that...)
might be that your home is on a partition mounted with noexec option?

btw I don't really see why KDE wants execute set on .desktop files... the 
programs they refer to certainly.. ;), but the .desktop files themselves? 
they are just launchers/links

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list