KDE 4.4 Desktop Icons/Application shortcuts error

JayLinux jaylinux53 at gmail.com
Thu Feb 25 08:47:55 GMT 2010

On openSUSE 11.2 with KDE 4.4:

On trying to run any application on the desktop, it gives an error
message, which shows the file as a <.desktop> file with a red
exclamation mark (?) and says that the file should be executable to
run (checking properties of the file, all are executable, as they are
applications/application shortcuts). This happens with all apps on
desktop: Firefox, OpenOffice.org Starter, etc. (Images [1], [2] -
these are for Firefox, but happens with any app/shortcut on the
desktop). It shows the same error message on trying to run the
app/shortcut subsequently also.
Image [3] is details of the properties for the desktop shortcut for Firefox.

I tried chmod +x -R /home/user/Desktop, but the problem persists.

However, the apps can be run from the Kicker /Classic KDE Menu.


[1] http://www.imagebam.com/image/27911547856333
[2] http://www.imagebam.com/image/78ebae47856335
[3] http://www.imagebam.com/image/fe396447856343

Linux User 483705 @ http://counter.li.org/ (Linux Counter)
This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list