How to save the desktop applets settings?

Duncan 1i5t5.duncan at
Thu Sep 24 06:26:04 BST 2009

paulo posted on Thu, 24 Sep 2009 12:33:23 +0000 as excerpted:

> I tried two things,
> 1- ctrl+alt+back space: restarted X > logged in > everything normal.
> This means that when I set the changes, it saves immediately, and not
> when the system (kde) shuts down.
> 2 - normal logoff > login > no good
> Here I get the "factory settings".
> So, I guess when KDE shuts down normally, it deletes or at least changes
> something in the configuration files. What and why I still don't know.
> Any ideas?

I just did a bit of investigation here, looking to see where plasma keeps 
all its cnfig, and found something a bit different than I expected.  I 
expected each applet to have its own config file, probably in 
~/.kde/share/apps/plasma (some distributions will use .kde4 or the like, 
instead of .kde, especially if they are setup so kde3 and kde4 can be 
used in parallel), but that's not how it worked.  The other location it 
would be, normally for apps with only a single config file, is ~/.kde/
share/config/, so since it's plasma, ~/.kde/share/config/
plasma<something>, and sure enough, that's where it was.  But the 
surprising bit for me was that it keeps all the plasmoid configs together 
in a single file, plasma-desktop-appletsrc (so that's the 
plasma<something>), as I expected each one to have its own.  DO NOTE THAT 
simply plasma-appletsrc instead of plasma-desktop-appletsrc, or 
something.  You can open it with a text editor and see if it has the sort 
of settings you'd expect... I have a weather applet, for instance, and it 
shows the city and other settings from it in one section, etc.

So that should be the file you're working with... unless the applet's 
doing something really strange, that is.

Now, try this.  Get everything setup as you want it.  Since all the 
plasmoids, panels, desktop, everything, is saved together, make sure it's 
all setup as you want it.  Then, set that file read-only, and make a 
second copy of it, say plasma-desktop-appletsrc.bak, or plasma-desktop-
appletsrc.2009.0923 (the date), or some such.  (I recommend you come up 
with a system that works for you, and use it consistently when doing this 
sort of thing.  .bak files are nice and easy, but every once in awhile 
you find an app that creates its own backups using .bak.  I used to use 
my initials, .jed, which is distinctive enough I know those files when I 
see them, but the date is nice and distinctive too, and immediately lets 
you know how old the file is when you come across it again.  So that's 
what I'm using now, most of the time.)

Now, logout and back in, and see if it kept the settings.  If it did, you 
know the read-only saved it -- just remember that no further changes will 
be saved unless you set it read-write again!

Talking about which, maybe check it and see if it's not already 
readonly!  But no, that shouldn't be it, or it'd probably not save the 
settings at all, no matter how you quit and restarted (Ctrl-alt-backspace 
or sane shutdown).

Anyway, if it kept the settings, you have a work-around, tho I'd still 
file a bug on it.

If it did NOT keep the settings...

First thing to check is whether the file is still the same as it was -- 
is plasma honoring the read-only, or simply overwriting it.  That's why I 
said make a second copy.  You can diff them (from a konsole window, or 
kompare them if you have kompare installed) and verify whether they're 
still the same and see what changed if not.

If it's overwriting, then that IS a bug.  Plasma should respect the 
permissions on its own config!

The other possibility is that the file's not changed, plasma is just 
ignoring the config for some reason.  I know ksysguard has this problem 
ATM.  While it's possible to set a running ksysguard a certain way, and 
it saves the config, and it loads it, it refuses to honor certain config 
settings and if it can, it'll save back the bad ones.  Setting the config 
read-only allows me to keep the proper config, but it doesn't do anything 
to solve the fact that ksysguard isn't honoring it properly!  It's 
possible your plasma applet as a similar bug of some sort.  But that 
doesn't really make sense either, because then whether you killed X not 
giving it a chance to save, or logged out sanely, it'd still have the 
same load behavior and it doesn't.  But anyway, maybe there's some other 
conditional involved too, for your plasmoid.

Anyway, hopefully setting it read-only will provide the workaround you 
need for the moment.  If it still doesn't, then there's yet another 
fallback we can use, or maybe it's not that file after-all, for that 
particular plasmoid.  Either way, we can cross that bridge if we get to 
it.  Hopefully the read-only trick will work and we won't have to worry 
about it.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:
More info:

More information about the kde mailing list