kde4 ksysguard aka system monitor

Duncan 1i5t5.duncan at cox.net
Tue Jul 21 14:04:44 BST 2009

Shaggy Wolf <shaggy.wolf.2006 at gmail.com> posted
200907210513.04355.shaggy.wolf.2006 at gmail.com, excerpted below, on  Tue,
21 Jul 2009 05:13:03 -0600:

> Don't know if this helps you or not but on my fresh gentoo install
> (accidentally deleted var and opt with no backups) my "System Monitor -
> Network" plasmoid is working correctly and I don't have knetworkmanager
> or networkmanager installed. If you are using wired internet all you
> would have to do is set it up in /etc/conf.d/net and it should be
> available to the kde network monitor. I am running kde 4.2.4 atm.
> HTH (or at least points you in the right direction) Scott

That helps a LOT, THANKS! =:^)

As for /var and /opt, /opt shouldn't be a big issue, (if /var hadn't been 
hit) just equery b /opt and see what it lists, then remerge it.  But /var 
is another story /entirely/, as among other things, that's where portage 
keeps its package database and world file, without which it hasn't a clue 
what's installed.

I've had a couple similar issues over the years, one "brown paper bag" 
issue (so-called because that's what you want to wear on your head so 
nobody can see who did the stupid thing) with a typo in a script run as 
root that caused it to do an rm -rf / instead of the subdir it was 
supposed to be in (due to an empty shell variable I didn't safety-check 
before using), and another when the AC failed... in Phoenix... in the 
summer... where it often hits 45 C (113 F) or higher in the shade... so 
the room could have hit 60 C (140 F) and who knows /what/ the spinning 
disks and running CPU hit... the CPU was fine after I got home and shut 
the system down for awhile, but the disk had head-crashed and had grooves 
wherever the head had tried to go.

The paper bag incident wasn't bad, as caught it relatively quickly, and I 
simply booted my alternate root (copied directly from my working root 
periodically when the system seems relatively stable), and restored from 
binpkgs, to current, as I run FEATURES=buildpkg.

The cooked disk issue was rather more serious, as the backup partitions 
still functioned (they weren't in use so didn't get grooved) but were 
rather more dated than they should have been, and because at the time I 
had separate /, /usr, and /var partitions, and I ended up with the backup 
version of one or two and the current version of one or two, meaning 
portage's package database was out of sync with what was actually 
installed on one or both of the other partitions.  While I was able to 
remerge from binpkg as above (this happened first, tho, the reason I was 
better prepared for the paper bag incident), thus getting a consistent 
picture of the latest packages installed, there were a LOT of orphaned 
files laying around from the old versions that hadn't been unmerged 
properly.  I had to clean those up manually (run a script that equery 
belonged each file in /usr/lib, for instance, making a list of what came 
up as unowned, then deciding what was legitimate unpackaged system files 
and what was orphans that needed deleted).  I learned my lesson, and now 
I not only keep the backups a bit better updated, but everything that 
portage touches is on the same partition as the portage database (/var/db/
portage), so it all stays in sync.  If I have to revert to the backup for 
whatever reason, it might be older, but it's all in sync and current from 
whenever I made that backup.  As I mentioned, that made cleaning up after 
the brown paper bag incident MUCH easier.

I also run 4-spindle SATA md/kernel RAID now, with the main system 
RAID-6, so I can lose two of the four drives without losing the data.  
And, whenever I'm gone for several hours in the summer now, I hibernate 
or shut down, so if the AC does die again, it won't hurt my system as 
it'll be off, not running as it was when I got that cooked drive.

Other than that, I do the emerge --emptytree system, followed by world, 
once in awhile when I upgrade gcc minor version or something, but in 
general, I'm still running the system I installed with Gentoo 2004.1, 
just about exactly a half decade ago now.  I've done rolling updates 
since then, keeping the system clean with revdep-rebuild and
emerge --depclean, plus those manual recoveries I mentioned above, and 
the system continues rolling along like it always has.

Anyway, based on your post, I know it's not a missing networkmanager 
dependency, now.  That's a good thing, as I was NOT wanting to install 
that wireless stuff.  But I still don't know what the problem is then.  I 
guess it's time to check the bug reports and/or see if there's any source-
code I can make sense of (not being a C/C++ coder, but being able to 
muddle thru it in many cases if it's reasonably well commented and the 
var names, etc, are well chosen).  Plus there's strace I can try, if it 
comes to it.

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list