missing config dialogs?

Matthew Woehlke mw_triad at users.sourceforge.net
Sat Jan 13 06:14:33 GMT 2007

Boyan Tabakov wrote:
> On 11.1.2007 07:52, Matthew Woehlke wrote:
>> If I run konsole in konsole (<g>), I see the following when I try to go
>> to 'configure konsole':
>> kdeinit: Got EXEC_NEW 'kcmshell' from launcher.
>> kio (KLauncher): kcmshell (pid 22139) up and running.
>> DCOP: register 'kcmshell-22139' -> number of clients is now 2
>> kio (KSycoca): Trying to open ksycoca from /var/tmp/kdecache-root/ksycoca
>> kcmshell (kdelibs): WARNING: Could not find module 'kcmkonsole'.
>> DCOP:  'kcmshell-22139' now known as 'kcmshell_'
>> DCOP: unregister 'kcmshell_'
>> kdeinit: PID 22139 terminated.
>> DCOP: unregister 'konsole-22032'
>> ...and similar results if I try to run 'kcmshell kcmkonsole' manually.
> Looks like you are missing some modules. See if you can find kcm_konsole.lo 
> and kcm_konsole.so in <kde-dir>/lib/kde3/. There should be some other kcm_* 
> files there too. Not sure what you should do if you are missing those though. 
> Maybe missed some config option before building?

Nope, not missing:

# ls /usr/local/kde/lib/kde3/kcm_konsole*

...but I did notice that the things that show up in 'kcmshell --list' 
all seem to have .desktop entries in kde/share/applications. The only 
.desktop for kcmkonsole is in share/applnk/.hidden, and it doesn't have 
a 'X-KDE-FactoryName' line in it. I tried copying it and adding the line 
(using 'kcm_konsole' of course), but no dice.

Any other thoughts? (Since this is starting to look like a build 
problem, maybe I should take it up with kde-devel?)

(sorry, no .sig rotator written yet)

This message is from the kde mailing list.
Account management:  https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

More information about the kde mailing list